summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2015-12-23 11:13:47 +0100
committerTomas Mozes <hydrapolic@gmail.com>2015-12-23 11:13:47 +0100
commita7b48c17cb68dc6133aea0e5f4231d972de962ca (patch)
tree71406c923534f37b0b09777d46f3c6fef14dde2a /dev-python/httmock/httmock-1.2.3.ebuild
parentdev-python/httmock: update manifest (diff)
downloadgentoo-a7b48c17cb68dc6133aea0e5f4231d972de962ca.tar.gz
gentoo-a7b48c17cb68dc6133aea0e5f4231d972de962ca.tar.bz2
gentoo-a7b48c17cb68dc6133aea0e5f4231d972de962ca.zip
dev-python/httmock: version bump to 1.2.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/httmock/httmock-1.2.3.ebuild')
-rw-r--r--dev-python/httmock/httmock-1.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/httmock/httmock-1.2.3.ebuild b/dev-python/httmock/httmock-1.2.3.ebuild
new file mode 100644
index 000000000000..c34228d46c0b
--- /dev/null
+++ b/dev-python/httmock/httmock-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A mocking library for requests"
+HOMEPAGE="https://github.com/patrys/httmock"
+SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}