summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-29 00:21:56 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-29 00:26:15 +0200
commit729d25ac2e2a7c935d339ee750352d54d6974f28 (patch)
tree97a20f4ca7bbfdb4280d00e13ecf5adadfa1371f /dev-python/httpauth
parentdev-python/geventhttpclient: add Python 3.7 (diff)
downloadgentoo-729d25ac2e2a7c935d339ee750352d54d6974f28.tar.gz
gentoo-729d25ac2e2a7c935d339ee750352d54d6974f28.tar.bz2
gentoo-729d25ac2e2a7c935d339ee750352d54d6974f28.zip
dev-python/httpauth: add Python 3.7, EAPI=7, make tests verbose
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/httpauth')
-rw-r--r--dev-python/httpauth/httpauth-0.3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/httpauth/httpauth-0.3.ebuild b/dev-python/httpauth/httpauth-0.3.ebuild
index 49c87f86fbe0..5d6c2a75af22 100644
--- a/dev-python/httpauth/httpauth-0.3.ebuild
+++ b/dev-python/httpauth/httpauth-0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -16,11 +16,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
python_test() {
- nosetests tests.py || die "tests failed with ${EPYTHON}"
+ nosetests -v tests.py || die "tests failed with ${EPYTHON}"
}