summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-20 23:25:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-21 00:10:26 +0100
commit0fa180234957edff1b09fa3e2478cfedd7df0216 (patch)
treedcd340c15abb0a2a348df96847b4c7ebbe17d4aa /dev-python/httpcore
parentdev-python/async_timeout: Bump to 4.0.2 (diff)
downloadgentoo-0fa180234957edff1b09fa3e2478cfedd7df0216.tar.gz
gentoo-0fa180234957edff1b09fa3e2478cfedd7df0216.tar.bz2
gentoo-0fa180234957edff1b09fa3e2478cfedd7df0216.zip
dev-python/httpcore: Bump to 0.14.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.14.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 484d518c7e83..e7460735ecd9 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1 +1,2 @@
DIST httpcore-0.13.7.tar.gz 64734 BLAKE2B e6c4b1720ce4bf62689995d3e1c648c4702bb416f3b3586eb8dd2f0cfd2155046e64181c4c04e65f721a5f0fcbc23b5ffd01c2930c7c69d37ee4c36e37b7d0d4 SHA512 0cc48828d0710066b3ef89998ec85975285763ac63a8b59106952ef2dac5a02dac71e7e106c4b6ea1022eb4d06a9cb5ee3e634eb564bad49c5508beff75279d6
+DIST httpcore-0.14.3.tar.gz 64650 BLAKE2B 140c55af60f54ff13db958cecef50af2b8857837c00c2e5b1ec48d8866bc08146f608864a3dcaed0014505ba0ea10b8d457a763ecf434a0d40a2e11debdd4003 SHA512 05e92109839c2e2f7ec81fea9507fb15a12d1bf6ae92048170953b1cb0139237b81c892feff1bc3840e06887e8916cadcc4124725874344524e45e3640a00379
diff --git a/dev-python/httpcore/httpcore-0.14.3.ebuild b/dev-python/httpcore/httpcore-0.14.3.ebuild
new file mode 100644
index 000000000000..6777fb94ef78
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.14.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.13[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest