summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 21:37:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:09 -0500
commit8b271aab0cbf692666da48a0f7958a4ebba6010f (patch)
tree51ae8af6f85904372436ddb7e8d5a1f44e760575 /dev-python/httplib2/httplib2-0.12.1.ebuild
parentdev-python/pastedeploy: 2.0.1 bump (diff)
downloadgentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.tar.gz
gentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.tar.bz2
gentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.zip
dev-python/httplib2: 0.12.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/httplib2/httplib2-0.12.1.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.12.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.12.1.ebuild b/dev-python/httplib2/httplib2-0.12.1.ebuild
new file mode 100644
index 000000000000..0d4ac24b5236
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/ https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="app-misc/ca-certificates"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.11.3-use-system-cacerts.patch )
+
+python_prepare_all() {
+ chmod o+r */*egg*/* || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} =~ ^(python2.7|pypy)$ ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}