summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-06-11 22:51:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-08-05 11:12:14 +0200
commitb88f50e3f0a22e4cf4110c257e6469f85b5c1c14 (patch)
treeb901f10bdb56bec99e39fa283f84540489f79a8f /dev-python/httplib2/httplib2-0.13.0.ebuild
parentdev-python/zict: version bump. (diff)
downloadgentoo-b88f50e3f0a22e4cf4110c257e6469f85b5c1c14.tar.gz
gentoo-b88f50e3f0a22e4cf4110c257e6469f85b5c1c14.tar.bz2
gentoo-b88f50e3f0a22e4cf4110c257e6469f85b5c1c14.zip
dev-python/httplib2: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/httplib2/httplib2-0.13.0.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.13.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.13.0.ebuild b/dev-python/httplib2/httplib2-0.13.0.ebuild
new file mode 100644
index 000000000000..ea68c21b0a1a
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/ https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="app-misc/ca-certificates"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+python_prepare_all() {
+ chmod o+r */*egg*/* || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} =~ ^(python2.7|pypy)$ ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}