summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 10:19:36 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 10:34:45 +0200
commitfbe6ff561b7a137fd273981ae77947d19b23fa75 (patch)
tree45b16fc8efa3fb7c6676c92347a79c5b7c9f7100 /dev-python/httplib2/httplib2-0.9.2-r1.ebuild
parentdev-python/apptools: Drop old (diff)
downloadgentoo-fbe6ff561b7a137fd273981ae77947d19b23fa75.tar.gz
gentoo-fbe6ff561b7a137fd273981ae77947d19b23fa75.tar.bz2
gentoo-fbe6ff561b7a137fd273981ae77947d19b23fa75.zip
dev-python/httplib2: Set readable bit for egg
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/httplib2/httplib2-0.9.2-r1.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.9.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.9.2-r1.ebuild b/dev-python/httplib2/httplib2-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..20df28421041
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.9.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.python.org/pypi/httplib2 https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_prepare_all() {
+ chmod o+r */*egg*/* || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2.7 ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}