summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 09:28:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 09:28:19 +0200
commit47c16b77686a0bc6e8e9f4bcfbcf2cf9dc08b29f (patch)
tree5dfc66ad2c9dd54b571b2f78f06798ea73a6b47f /dev-python/httplib2/httplib2-0.9.2.ebuild
parentdev-python/enable: Version Bump and fix for newer swig (diff)
downloadgentoo-47c16b77686a0bc6e8e9f4bcfbcf2cf9dc08b29f.tar.gz
gentoo-47c16b77686a0bc6e8e9f4bcfbcf2cf9dc08b29f.tar.bz2
gentoo-47c16b77686a0bc6e8e9f4bcfbcf2cf9dc08b29f.zip
dev-python/httplib2: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/httplib2/httplib2-0.9.2.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.9.2.ebuild b/dev-python/httplib2/httplib2-0.9.2.ebuild
new file mode 100644
index 000000000000..78cdde8b65ba
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.python.org/pypi/httplib2 https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_test() {
+ if [[ ${EPYTHON} == python2.7 ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}