summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-09 10:13:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-09 10:20:15 +0100
commit01fa5e8e750b5d0baa16ff7f7bd27fcffc247713 (patch)
treea10004253eae73d7e3a23540281288c5d55988b9 /dev-python/httplib2
parentwww-apps/gitea: remove old (diff)
downloadgentoo-01fa5e8e750b5d0baa16ff7f7bd27fcffc247713.tar.gz
gentoo-01fa5e8e750b5d0baa16ff7f7bd27fcffc247713.tar.bz2
gentoo-01fa5e8e750b5d0baa16ff7f7bd27fcffc247713.zip
dev-python/httplib2: Bump to 0.19.0
Bug: https://bugs.gentoo.org/769653 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.19.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index c4f54fc1445a..64c843876d88 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1 +1,2 @@
DIST httplib2-0.18.1.tar.gz 262930 BLAKE2B d8130dfbbee71dae1319a8a65fb2ae96d667bba08cfc586c0a9239d6bf6cb475fbd4548d6b5276b8001a02417eebff4a7565024d43c630b8ed51e467cdd3de71 SHA512 a1bb527279bdc92fb75bffebc317ff549bb6efb678580cbe40d187921b7ace66b1a5bc1d98bdf065ec5667fe69632da086b0eb201ff911497324fd817bfe1b7a
+DIST httplib2-0.19.0.tar.gz 263522 BLAKE2B b35c8dcf86de17a5d8eac86a9a6b4110fb247925662e24a7645a67dfd0b2e640dc29875b41673c5a91a083f17e9619fd40dd08cf2c9ee7f48c8069bc14a50966 SHA512 9193a0e8e9a58a3f0e9b27fdf827932482a47b88af297af6e5f004164ca0b72feeff513b8191bf7c48d6714070a1390ae54eb8a2c6840f54f2580889c7837c7f
diff --git a/dev-python/httplib2/httplib2-0.19.0.ebuild b/dev-python/httplib2/httplib2-0.19.0.ebuild
new file mode 100644
index 000000000000..dfc3b4967676
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.19.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="app-misc/ca-certificates"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # broken by using system certificates
+ tests/test_cacerts_from_env.py::test_certs_file_from_builtin
+ tests/test_cacerts_from_env.py::test_certs_file_from_environment
+ tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
+
+ # broken by new PySocks, probably
+ tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
+ tests/test_proxy.py::test_socks5_auth
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ # known pypy3.7 bug
+ # https://foss.heptapod.net/pypy/pypy/-/issues/3396
+ tests/test_https.py::test_sni_set_servername_callback
+ )
+
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ pytest -vv ${deselect[@]/#/--deselect } tests ||
+ die "Tests fail with ${EPYTHON}"
+}