summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-18 10:11:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-18 10:16:46 +0100
commit071620731d76f5cb096622ab2581bf79eaf618da (patch)
tree3ab60f57b7aee9a2de974008797db5d01940b8a0 /dev-python/httplib2
parentdev-python/pyproj: Bump to 3.3.0 (diff)
downloadgentoo-071620731d76f5cb096622ab2581bf79eaf618da.tar.gz
gentoo-071620731d76f5cb096622ab2581bf79eaf618da.tar.bz2
gentoo-071620731d76f5cb096622ab2581bf79eaf618da.zip
dev-python/httplib2: Bump to 0.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.20.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index 2cee1e7e3ce7..f8fd61900192 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1 +1,2 @@
DIST httplib2-0.19.1.tar.gz 263971 BLAKE2B ec254249f5c8df2a0dc3fe4e2e9088f6ca14ba84516be77450beacab41cd295d4e741ac6026471fcf8bb8464ebd732a0a856901e5c09324a0f96ad2338b397e7 SHA512 0c87b3c9923e81c83df5257ce60f7248d86a64aea0a02d5a3f34be68c692c6abd896f95214899dc6e81b23677efc7684a3cba4c1a47261176dd26c3988054e55
+DIST httplib2-0.20.2.gh.tar.gz 407815 BLAKE2B ebb3a35b5842eff570c4d804e5dcffa5afde32841eaf1797afd47a58ff7e4d6f945b20c82ad10afe0abff1dd8c5fb405594dca0c6641f8a7a201a71258478c52 SHA512 cb1e0e365ec7872d20c1a8e3ddb150433dd01f4ec816ae2044be6aad6c21afd00ce00dfc57f1348dcc857a63e02e8ffbd39c78f35bb4bba2e283a48f07102159
diff --git a/dev-python/httplib2/httplib2-0.20.2.ebuild b/dev-python/httplib2/httplib2-0.20.2.ebuild
new file mode 100644
index 000000000000..97e80595b6c9
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.20.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/"
+SRC_URI="
+ https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ app-misc/ca-certificates
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-libs/openssl
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ # the bundled certificates use weak MDs
+ pushd tests/tls >/dev/null || die
+ ../../script/generate-tls || die
+ popd >/dev/null || die
+
+ # recerting increases serial numbers
+ sed -e 's:E2AA6A96D1BF1AEC:E2AA6A96D1BF1AEF:' \
+ -e 's:E2AA6A96D1BF1AED:E2AA6A96D1BF1AF0:' \
+ -i tests/test_https.py || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by using system certificates
+ tests/test_cacerts_from_env.py::test_certs_file_from_builtin
+ tests/test_cacerts_from_env.py::test_certs_file_from_environment
+ tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
+
+ # broken by new PySocks, probably
+ tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
+ tests/test_proxy.py::test_socks5_auth
+
+ # broken by recerting (TODO)
+ tests/test_https.py::test_min_tls_version
+ tests/test_https.py::test_max_tls_version
+ )
+
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ epytest tests
+}