summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-26 00:34:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-26 00:34:48 +0100
commit23fa08ef47134c15140230edd7aaa534cc973fca (patch)
tree78432cb0d9e1947f0d457f9ef7e7704db34131c6 /dev-python/httpretty
parentdev-python/importlib_metadata: Remove old (diff)
downloadgentoo-23fa08ef47134c15140230edd7aaa534cc973fca.tar.gz
gentoo-23fa08ef47134c15140230edd7aaa534cc973fca.tar.bz2
gentoo-23fa08ef47134c15140230edd7aaa534cc973fca.zip
dev-python/httpretty: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest2
-rw-r--r--dev-python/httpretty/httpretty-0.9.6.ebuild43
-rw-r--r--dev-python/httpretty/httpretty-1.0.2-r1.ebuild49
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index bad5cea5721b..09b1d35e84c1 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1,3 +1 @@
-DIST httpretty-0.9.6.tar.gz 7147633 BLAKE2B e1d02ddfce5ca987c6ef1a17723544f86a8573c2a6a26ec197072021e52015efce5064af21bfbe1ec03f3ac11c21717a80f114b5be2526b113e3bc0a608702f4 SHA512 bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92
-DIST httpretty-1.0.2.tar.gz 399185 BLAKE2B 033e954fccf6a351c09dac3c1585ddc65f064eca109dfd8f499fd510ea09ba3ce5198d3f4b54fb832b47425ab721ddc1b2da596b6066028bda1f0a1303cdc0ed SHA512 f9ef1c82f4fe3a31696e06228cea512664c5118b3c32910d7810d1fcf16b05d31b9b55db7bb6bd64967aadb162a2952757627439769db9117164b8248de9049c
DIST httpretty-1.0.3.tar.gz 411707 BLAKE2B b2211457c937e19f8110bc28446a2b78a8042a742341c0492589def7447e819f051d301e9d254260778f349302ccf6fc163a9f2280a55af925ae353752450320 SHA512 a6349257376c12198d0bf7923245c34f6b8a0889946ba0c2551fd3379a8d9a8e4610de81c66f945656c1879ad3fb1485f2f4148634fcc4e156b9f0a59f7dd758
diff --git a/dev-python/httpretty/httpretty-0.9.6.ebuild b/dev-python/httpretty/httpretty-0.9.6.ebuild
deleted file mode 100644
index 512384afe0fc..000000000000
--- a/dev-python/httpretty/httpretty-0.9.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
deleted file mode 100644
index 12c6a2505f07..000000000000
--- a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-# redis skipped as it requires a redis server running
-DEPEND="
- test? (
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
- # requires running redis server
- # it is skipped correctly but it causes unnecessary dep on redis-py
- rm tests/functional/bugfixes/test_redis.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}