summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 11:21:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 11:21:24 +0200
commit47e4bedd284f1b2e9874e6cefceed93310be5ba1 (patch)
treeee0e7e8a1be61bdb4b9243c6e584923e14a2be32 /dev-python/httpretty
parentdev-python/googleapis-common-protos: Remove old (diff)
downloadgentoo-47e4bedd284f1b2e9874e6cefceed93310be5ba1.tar.gz
gentoo-47e4bedd284f1b2e9874e6cefceed93310be5ba1.tar.bz2
gentoo-47e4bedd284f1b2e9874e6cefceed93310be5ba1.zip
dev-python/httpretty: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/httpretty-1.1.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/httpretty/httpretty-1.1.4.ebuild b/dev-python/httpretty/httpretty-1.1.4.ebuild
deleted file mode 100644
index ebb43b2a8e5d..000000000000
--- a/dev-python/httpretty/httpretty-1.1.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-# eventlet is used only to test compat, and it doesn't support py3.10
-# redis skipped as it requires a redis server running
-BDEPEND="
- test? (
- >=dev-python/boto3-1.17.72[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.18.1[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
-
- distutils-r1_python_prepare_all
-}