summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:39 +0200
commita2cfd88f525fade2a834a5e910c6dcef9c152916 (patch)
treed33998e6b408774f512a4b4be00680783e6c4d2e /dev-python/httpretty
parentdev-python/hpack: Remove redundant versions (diff)
downloadgentoo-a2cfd88f525fade2a834a5e910c6dcef9c152916.tar.gz
gentoo-a2cfd88f525fade2a834a5e910c6dcef9c152916.tar.bz2
gentoo-a2cfd88f525fade2a834a5e910c6dcef9c152916.zip
dev-python/httpretty: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/httpretty-1.0.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/httpretty/httpretty-1.0.2.ebuild b/dev-python/httpretty/httpretty-1.0.2.ebuild
deleted file mode 100644
index 448717cb08c7..000000000000
--- a/dev-python/httpretty/httpretty-1.0.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}