summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 00:07:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 00:07:23 -0500
commitd38b3efde38944496f773812545581ca577a45a7 (patch)
tree1ea9034b614b015bf2d0c77e07b2a916e18407f9 /dev-python/httpretty
parentdev-python/pysaml2: bup with py34 support (diff)
downloadgentoo-d38b3efde38944496f773812545581ca577a45a7.tar.gz
gentoo-d38b3efde38944496f773812545581ca577a45a7.tar.bz2
gentoo-d38b3efde38944496f773812545581ca577a45a7.zip
dev-python/httpretty: adding older needed version for oslo-policy
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-0.8.6.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index 342c28d35052..6cf6236e397f 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -2,3 +2,4 @@ DIST httpretty-0.7.0.tar.gz 28066 SHA256 a422a74fe0f35fbb644c9a3a0a4ccb7a7469a8f
DIST httpretty-0.7.1.tar.gz 28394 SHA256 a0f61cd3fbdffd28a556f8fd5eff703ad3c5c76cf0c39ab8bc136f38d0a71857 SHA512 53b6f063e0e7863fa77aad1eebb0ad3078528bc97d26df80a3c6491c42b9a9008080da35bbb1e9372674c996f25e5109c84b48a2a6d9f0de5b7c53331bdad857 WHIRLPOOL 2112692eeaa034f6afa3b7ef76aa557f3211b0f9db9178369446148b7c1d8eb6292f51a47c767d168222a7d40ed66bfefd1557bbb1c9ee3c5394e1c524861e4b
DIST httpretty-0.8.0.tar.gz 34291 SHA256 e5512b38ad3bfb9f7d275c957b4a7eddc69e4b3a749e3b62a984c86fb6ab329b SHA512 0c6193c488a27345b3d98cc6a62e8933b67828b7335700367b28cf328ef86ff2342056bada84ca631d6acc5650b7b456e80d85d8099e873f07cd41140c481650 WHIRLPOOL f828e84fddc6e4ab9671a9cd33da6b0f2b4053fc3368e3119ed5d7410cde125486aaae8bcf1cf4eab3a641af48dda7c6531c231f0d59c36d65f1c3d173e8969f
DIST httpretty-0.8.10.tar.gz 41741 SHA256 474a72722d66841f0e59cee285d837e1c6263be5be7bf2f8e824fc849a99adda SHA512 5bc734a89c45daa746551ef7d150c02bf6d9cddf1bc5426a8800d2241bb5bf8a834d2736fd9a4846ce150747d9c2064686a3ed63e97e5f131778d834956a9107 WHIRLPOOL 33fc4c025176c9d3493f8efe67f24db90d2c799536a949d490be4d9c11918190846d2612c6b09e6e000430a70f0e54b9bac87261cae62e5ba8ef558251f2bc3b
+DIST httpretty-0.8.6.tar.gz 40815 SHA256 36bd574d289ee5ad781e28abb1f9cb6af696c27f13200769caf48a23e42f4938 SHA512 bd5d0b1a33b52ae3d0e09673429e771ce582795bf58d38b34d4df39f74b377ec199d720fa061a84b64175b6ba67a91bdb35c242b4fd754627d2744cb8b33b313 WHIRLPOOL 0803c822bfff000c7bc5630f29ca08232e50a1a8786122179471c84d5630281e8e2a746f820b027f6357eee77b8ece46275cb1b1cf25d957a5e785c6c9220d5b
diff --git a/dev-python/httpretty/httpretty-0.8.6.ebuild b/dev-python/httpretty/httpretty-0.8.6.ebuild
new file mode 100644
index 000000000000..f57ba10d38c5
--- /dev/null
+++ b/dev-python/httpretty/httpretty-0.8.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.5[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+ dev-python/ipdb[${PYTHON_USEDEP}] )"
+
+#Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ # https://github.com/gabrielfalcao/HTTPretty/issues/125, still occur
+ # py3.4 hangs on many tests and is deemed underdone
+ # Upstream does not make it clear whether py3.4 is sctually tested and supported.
+ # python2.7 has substantial failure in tests/functional/test_requests.py and is removed.
+ # Some tests excluded attempt connection to the network
+ # On testing in the state below, py2.7 still has a tally of FAILED (failures=5)
+ # that occur within the folder tests/unit which upstream should address.
+ # https://github.com/gabrielfalcao/HTTPretty/issues/236 Bug #532106
+
+ if [[ "${EPYTHON}" == python3.4 ]]; then
+ einfo "python3.4 not adequately supported in testsuite"
+ elif [[ "${EPYTHON}" == python2.7 ]]; then
+ rm -f tests/functional/test_requests.py || die
+ nosetests -e test_recording_calls \
+ -e test_playing_calls \
+ -e test_callback_setting_headers_and_status_response \
+ -e test_httpretty_bypasses_when_disabled \
+ -e test_using_httpretty_with_other_tcp_protocols \
+ tests/unit \
+ tests/functional || die "Tests failed under python2.7"
+ else
+ nosetests -e test_recording_calls \
+ -e test_playing_calls \
+ -e test_callback_setting_headers_and_status_response \
+ -e test_httpretty_bypasses_when_disabled \
+ -e test_using_httpretty_with_other_tcp_protocols \
+ tests/unit \
+ tests/functional || die "Tests failed under python3.3"
+ fi
+
+ rm -rf "${BUILD_DIR}"/../tests/ || die
+}