summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-10 13:56:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-10 16:28:57 +0100
commitd7b7db2aa3b62ff2a8b4a42b1f78c4c41898e6f0 (patch)
treedb109b0687cda440a4b75bf5e6b811d0a3a25bc6 /dev-python/httpretty
parentdev-lang/python: Bump to 3.7.7 (diff)
downloadgentoo-d7b7db2aa3b62ff2a8b4a42b1f78c4c41898e6f0.tar.gz
gentoo-d7b7db2aa3b62ff2a8b4a42b1f78c4c41898e6f0.tar.bz2
gentoo-d7b7db2aa3b62ff2a8b4a42b1f78c4c41898e6f0.zip
dev-python/httpretty: Bump to 0.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-0.9.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index f9a8c98a04d7..71be5aee824a 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1,2 +1,3 @@
DIST httpretty-0.8.14.tar.gz 43574 BLAKE2B 4015bb234c2fe3017a43fff6e3b51a7f015d9d133756d4326750da1ea06ce1910d91d7b47625a08ec85856d156a0d8b3b18706e582578e3d186994b8e4f55c69 SHA512 5adab6450e8360cc21bab4136f64cd11757b9f292c7e27980fe2561f3e705baf4f0211b9e6ff4ec9ba96a788a6c5b5b1d26657972b67423c9c25491927b0884b
DIST httpretty-0.9.6.tar.gz 7147633 BLAKE2B e1d02ddfce5ca987c6ef1a17723544f86a8573c2a6a26ec197072021e52015efce5064af21bfbe1ec03f3ac11c21717a80f114b5be2526b113e3bc0a608702f4 SHA512 bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92
+DIST httpretty-0.9.7.tar.gz 6967749 BLAKE2B e2192871ca4f0f0c0bc7c39570251d26a6d78b6e5aabb1857df2b5c3533ae066400fca323d53e1790bfa2a1509e8ebb87d20d49659620087ca3c3765648662ec SHA512 4a1cdfc09af14ab2bc6eec84ad0905103ffb48c3154b127f646b39ff131584a52b1fd56bfe7a41959fc68d64eff94a221f9bf5a159a3dbfb3535fe4ac76c6170
diff --git a/dev-python/httpretty/httpretty-0.9.7.ebuild b/dev-python/httpretty/httpretty-0.9.7.ebuild
new file mode 100644
index 000000000000..54886415f6ce
--- /dev/null
+++ b/dev-python/httpretty/httpretty-0.9.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}