summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-02-23 18:01:17 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-02-24 01:04:49 +0100
commitb5dc6c977c60efae257f408911e3e57141deafb9 (patch)
tree8c8e3806388fd61b41a0dcd0a6e61f2ca90996ac /dev-python/httpx
parentdev-python/httpcore: new package, version 0.12.3 (diff)
downloadgentoo-b5dc6c977c60efae257f408911e3e57141deafb9.tar.gz
gentoo-b5dc6c977c60efae257f408911e3e57141deafb9.tar.bz2
gentoo-b5dc6c977c60efae257f408911e3e57141deafb9.zip
dev-python/httpx: new package, version 0.16.1
New dependency of dev-python/denonavr. dev-python/uvicorn will be added in the next commit. Package-Manager: Portage-3.0.14, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest1
-rw-r--r--dev-python/httpx/httpx-0.16.1.ebuild45
-rw-r--r--dev-python/httpx/metadata.xml13
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
new file mode 100644
index 000000000000..f0d4a82982b3
--- /dev/null
+++ b/dev-python/httpx/Manifest
@@ -0,0 +1 @@
+DIST httpx-0.16.1.tar.gz 965347 BLAKE2B a6c5bcdda595ffcfb824194564ebd93760a9180e60665a9540fc6a2822b1be4273b940fee61cb4b49c2d97a5f4d71b1caf32deddec18d2fb636465b3868aece4 SHA512 d76b2c94c655c187ab150f20b16906034574d017a67c4a06c456d55071434cc0ba7752bdceda86aa6b1a1fe9109fa11594e4ea679cd7d2a77898fb40fa5153d3
diff --git a/dev-python/httpx/httpx-0.16.1.ebuild b/dev-python/httpx/httpx-0.16.1.ebuild
new file mode 100644
index 000000000000..aff93e055f9e
--- /dev/null
+++ b/dev-python/httpx/httpx-0.16.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="https://www.python-httpx.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ =dev-python/httpcore-0.12*[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
+ <dev-python/rfc3986-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/hyper-h2[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Require Internet access
+ sed -i 's/test_async_proxy_close\|test_sync_proxy_close/_&/' \
+ tests/client/test_proxies.py || die
+ # trio is not currently in the tree
+ sed -i '/^import trio/d' tests/concurrency.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/httpx/metadata.xml b/dev-python/httpx/metadata.xml
new file mode 100644
index 000000000000..8749dfa631bc
--- /dev/null
+++ b/dev-python/httpx/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">httpx</remote-id>
+ <remote-id type="github">encode/httpx</remote-id>
+ <bugs-to>https://github.com/encode/httpx/issues</bugs-to>
+ </upstream>
+</pkgmetadata>