summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-29 10:15:11 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-29 19:49:13 +0100
commit18326a851efbd2236455e1ea9b9e8434e55bc999 (patch)
tree6b677d15b7f8af3312ed47f11b23c24b52315ab7 /dev-python/humanfriendly/humanfriendly-2.4.ebuild
parentgnome-extra/gnome-calendar: bump to 3.22.5, fixing crash when adding and edit... (diff)
downloadgentoo-18326a851efbd2236455e1ea9b9e8434e55bc999.tar.gz
gentoo-18326a851efbd2236455e1ea9b9e8434e55bc999.tar.bz2
gentoo-18326a851efbd2236455e1ea9b9e8434e55bc999.zip
dev-python/humanfriendly: Version Bump and Py3.6 support
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-2.4.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-2.4.ebuild b/dev-python/humanfriendly/humanfriendly-2.4.ebuild
new file mode 100644
index 000000000000..c4b229c3b9d6
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/monotonic[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/capturer-2.1[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+python_test() {
+ esetup.py test
+}