summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-12-24 12:47:16 -0800
committerBrian Dolbec <dolsen@gentoo.org>2016-12-24 13:16:58 -0800
commit7a89e3f10b8cf93f636146dd6f364aa21761e815 (patch)
tree5260932e9ecd820f069db50058bc1a973640d684 /dev-python/hyper-h2
parentdev-python/pyGPG: Remove einfos belonging to another pkg (diff)
downloadgentoo-7a89e3f10b8cf93f636146dd6f364aa21761e815.tar.gz
gentoo-7a89e3f10b8cf93f636146dd6f364aa21761e815.tar.bz2
gentoo-7a89e3f10b8cf93f636146dd6f364aa21761e815.zip
dev-python/hyper-h2: Version bump
I have dropped the test use flag and code. Upstream does not include all the files necessary to run the tests and says that it has little interaction with other code, so integration tests are not needed. Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-python/hyper-h2')
-rw-r--r--dev-python/hyper-h2/Manifest1
-rw-r--r--dev-python/hyper-h2/hyper-h2-2.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hyper-h2/Manifest b/dev-python/hyper-h2/Manifest
index 67cada9d07fd..b4da6e1ae66b 100644
--- a/dev-python/hyper-h2/Manifest
+++ b/dev-python/hyper-h2/Manifest
@@ -1,3 +1,4 @@
DIST hyper-h2-2.4.0.tar.gz 77440 SHA256 c673efad0b8ee3c3c604375dd5e0c3dbc74f3c4e0385dae120d22b7d6f6ec301 SHA512 76835d6c97d4aed515b460bdbbcb8aea1ea061a416386cadf66a0e9b3c213a9ffe67948ce49b922d99e1895615a03159aa6aed198857e1ce73eb734b8bd9a016 WHIRLPOOL 9a5c1d313f53ee842403c77a8324aa432ff3d04d3d3737f6f7da83e5ff85e51ea6794419fa8886368cf34d4a7be3ff3b7ed19eb13a74ef8318fad738a71b9ef4
DIST hyper-h2-2.4.1.tar.gz 78056 SHA256 a914161895f60a16d7049386c77f2eee72af7fd49b117856033906e16110c9f4 SHA512 f7a29350a3f31740acf6fc199fb5f3fa06d751abcfbf5a2742370c40c656417ccc659d49b9754e5faeb09ad121c362a478076af81325644d04473d56fc83b07a WHIRLPOOL 4917deb305cca78a6cc8fcfeb34e8f4ef8982c213edc7c3f242422e992d1105ccb151168ad7387fd53faca6061a693cf76f7cb3f91880470cd7bf03bb7a73b26
DIST hyper-h2-2.5.0.tar.gz 92558 SHA256 6c1512798f2ec2f178b5eed80be3c5239145d23989a1ff3c7cc635ee679cc241 SHA512 f7141da1ce6bd7b27486a0f091c62fea6ccb6fad84bd97b024b611e4d76b7a056cee6a63c179268b324673671dd833981e00dc32c441f340f5c472828f6e62a2 WHIRLPOOL 5e7c5e8d5ab1491427abda81c8c133017cf0b35aaa2601b393c0a24844a7e7988efea1401a72ef08dca04d8e389c89a70272f13f48c90675a05aa9766afbcbb5
+DIST hyper-h2-2.5.1.tar.gz 92713 SHA256 673937480f97ad5a1fc8d78ff937352083c82525905b0f631db841c776a91f76 SHA512 e82a7e6b592b43d74defbd4c729ad287ed019881f6ddf0d2dff9d3eb4fdba29cab8d988848ec64b693da77df5cbcacb06eecf1ecd77843c66c9eea8808fc949c WHIRLPOOL cc1d761bc636fcdb1d760c04676c50427d6a0940bf739244e738506982116338e108a4d2d2dc016127894d1dea842709a2f667239cdd9320e4f1fcc73e7c86bb
diff --git a/dev-python/hyper-h2/hyper-h2-2.5.1.ebuild b/dev-python/hyper-h2/hyper-h2-2.5.1.ebuild
new file mode 100644
index 000000000000..cc8be2fa5e59
--- /dev/null
+++ b/dev-python/hyper-h2/hyper-h2-2.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+MY_PN="h2"
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="http://python-hyper.org/h2 https://pypi.python.org/pypi/h2"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/hyperframe-4.0.1[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '<dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+