summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-26 08:14:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-26 08:52:05 +0200
commit25a69b03b20398e7806cd851fb13026ac5d5e838 (patch)
tree507407cabc52ae01bfbd2c81609992b6ee950860 /dev-python/hypothesis
parentdev-python/patsy: Bump to 0.5.2 (diff)
downloadgentoo-25a69b03b20398e7806cd851fb13026ac5d5e838.tar.gz
gentoo-25a69b03b20398e7806cd851fb13026ac5d5e838.tar.bz2
gentoo-25a69b03b20398e7806cd851fb13026ac5d5e838.zip
dev-python/hypothesis: Bump to 6.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.23.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 999a27d5d67d..c999cb518262 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-python-6.17.4.tar.gz 9144209 BLAKE2B b110e355b34f386c51e9edeb2589bf11e5d0b574ee7e97437f9eba9ec7d8e823e68ad1e4f5911a1e78f3d5a316f59056301b0238c4b6a8cdcb21e46ea434686c SHA512 95eeadc1655d249008897035660af54f66e8ea78fea78d1069dbddb979505e003d1bdb971371769e90af4a7bc5f96ee0c42a6c14bc42e56677d4f89f39985d41
DIST hypothesis-python-6.21.6.tar.gz 9166313 BLAKE2B 19ac66c1674be30e14d54faa61244ac6da5b67678da4c5dbc728fefcac2e5f0a99c31f7cbe6fc4bc8738e1b072b4accba6f97863e6d601303d4fd69d4ccbd96a SHA512 454434f37dfc3f171d1865ac72d58821173654fabdd880c1b699ea0ff281405644bb1b370129843d35368cd9b6eb06fa00458e0aa41b2b7dc0b7e05e7f659a5d
DIST hypothesis-python-6.22.0.tar.gz 9166539 BLAKE2B 386c7fd4f9ff0d4d199f686f25743793de4de9f2676cf7c36c16519f5fef007f6b677bd5ef84fa975389c5fea9989dffffc8a18923699c05fecc23ef2e4dc5e6 SHA512 92352a7ba13d8a06532c6fcdb965f156c43369f18ba7c46808d9b6dde1ccdd5b4f938c1ce575d5651835bfe981d22e7a68189c93a368420c915f5d1ce9b8a205
+DIST hypothesis-python-6.23.0.tar.gz 9166945 BLAKE2B 89d8a642262dfcbd36d83343c5e632653808711e186f5afae360e870eaacf050b415fd1abeb589b375136f273a53a236da8e4ab6227d94e16c58c8e9d0d3d8a9 SHA512 43d5f1a21d555e2a7942414cfb185e9201d9c5198c12551db7a50f3f118fed4dddc934767a0e7d880dfd044ac1a062b64afc92c5c3f391cedf71b829e177f21d
diff --git a/dev-python/hypothesis/hypothesis-6.23.0.ebuild b/dev-python/hypothesis/hypothesis-6.23.0.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.23.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}