summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 10:15:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 10:20:22 +0100
commit2d7dff861ff69b8fe029906fa2e92dd1973c3ae0 (patch)
treed9b0db803ccbfeef340e1c3dd916b683139f5273 /dev-python/hypothesis
parentdev-python/pykka: Bump to 2.0.3 (diff)
downloadgentoo-2d7dff861ff69b8fe029906fa2e92dd1973c3ae0.tar.gz
gentoo-2d7dff861ff69b8fe029906fa2e92dd1973c3ae0.tar.bz2
gentoo-2d7dff861ff69b8fe029906fa2e92dd1973c3ae0.zip
dev-python/hypothesis: Fix installing for tests
Closes: https://bugs.gentoo.org/756853 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/hypothesis-5.37.5.ebuild5
-rw-r--r--dev-python/hypothesis/hypothesis-5.41.3.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-5.37.5.ebuild b/dev-python/hypothesis/hypothesis-5.37.5.ebuild
index a18c69ab7a35..18d37e55ce1b 100644
--- a/dev-python/hypothesis/hypothesis-5.37.5.ebuild
+++ b/dev-python/hypothesis/hypothesis-5.37.5.ebuild
@@ -48,6 +48,11 @@ python_prepare() {
}
python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
pytest -vv tests/cover tests/pytest tests/quality \
-n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
die "Tests fail with ${EPYTHON}"
diff --git a/dev-python/hypothesis/hypothesis-5.41.3.ebuild b/dev-python/hypothesis/hypothesis-5.41.3.ebuild
index b817839fd0ac..a3cf894856ae 100644
--- a/dev-python/hypothesis/hypothesis-5.41.3.ebuild
+++ b/dev-python/hypothesis/hypothesis-5.41.3.ebuild
@@ -48,6 +48,11 @@ python_prepare() {
}
python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
pytest -vv tests/cover tests/pytest tests/quality \
-n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
die "Tests fail with ${EPYTHON}"