summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-28 08:15:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-28 08:53:37 +0200
commit372d907434135810825986d418059ddd5b885bcf (patch)
tree4f690bf0b929071d2cebeaa4cc715e0f53a4af95 /dev-python/hypothesis
parentdev-python/openstacksdk: Bump to 0.59.0 (diff)
downloadgentoo-372d907434135810825986d418059ddd5b885bcf.tar.gz
gentoo-372d907434135810825986d418059ddd5b885bcf.tar.bz2
gentoo-372d907434135810825986d418059ddd5b885bcf.zip
dev-python/hypothesis: Bump to 6.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.17.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 26f61c728093..e57486d1af12 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.14.8.tar.gz 9137594 BLAKE2B 421c3fdb13e172bdb93cd15f625
DIST hypothesis-python-6.14.9.tar.gz 9138640 BLAKE2B 3cda0edace7b3a1c373bdd61267013874fe78ae18aa7fda02759ac451f7e576614a61c3ce1d588e24afe4333f61680d89eb30f6f055e41fee91312c791b1af5d SHA512 a32d4f09ae6a44354d136164a517ea53c653fccb3e21a39ac63df78ebdf695c887f13749d2f310ac67863b6645a85dca73ef0bfab077aefe0486e445f6a85dce
DIST hypothesis-python-6.15.0.tar.gz 9138803 BLAKE2B 537d40d2f86b16730391e4f4f7fc692d882793b47854f1645eb587dddf41e37e27f74588c8fb8829e0b0ceb2b563f8f88006f8be6dd28c954be59ba76b81e8e6 SHA512 19b8b5d71156c08d77c11b6d675cca3df1a66beec493e2a52600e14c2d1444f42f58b55ed769f9d99c16dc6844da1843539b995bb972daa6bbd35480edc444ed
DIST hypothesis-python-6.16.0.tar.gz 9140064 BLAKE2B 74d2963f71b357c1fcf5410271ef80a3f4f3540130c8e7ae5ec4408c07577962e30096d702a9feab25fa222cf23d85d865e816d661b8d5828570800b04453ef1 SHA512 92d98cb0a042d4abca9191ac46af6693ae2223433772622d33cd0838d2805fa72491421920af853ce258ec169037829ea1f924f35264d98319e2e0e3e7135f71
+DIST hypothesis-python-6.17.0.tar.gz 9142908 BLAKE2B e366f5355e13471c211e91a54fc70e46e3c575d06352968ce4ec3f5cbae0c5442d07c5fefb0907664f262f3ddd1fc50f202d4e93deedea380221e9cba796f0b5 SHA512 320dddaa88a697e6b2fdd942fc08bce0cb1c49f4eeb0de39a7d404d98971d60b0edb332d9d2dd5f3a63b37301d458e361ebd995ccca6554e784e772a7cb3ed6f
diff --git a/dev-python/hypothesis/hypothesis-6.17.0.ebuild b/dev-python/hypothesis/hypothesis-6.17.0.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.17.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}