summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-03 17:11:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-03 19:00:41 +0200
commit48c806ab757ab26319573c182bf4c854a7d4778a (patch)
tree9557abe0531f2a45a5887349f56fb293c0bf1433 /dev-python/hypothesis
parentdev-python/dask: Bump to 2.29.0 (diff)
downloadgentoo-48c806ab757ab26319573c182bf4c854a7d4778a.tar.gz
gentoo-48c806ab757ab26319573c182bf4c854a7d4778a.tar.bz2
gentoo-48c806ab757ab26319573c182bf4c854a7d4778a.zip
dev-python/hypothesis: Bump to 5.37.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.37.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 8bc91f6d2f9d..4cefd67cee87 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-5.35.4.tar.gz 9084892 BLAKE2B 5545f2b1f3e97eafb4c83d7918f
DIST hypothesis-python-5.36.0.tar.gz 9086288 BLAKE2B 9deba5f50168185d5e9ef35a47bcb0dc6dfdf38b7da7a2aedee0a6fe18740fa9a353b0985e25a40da1a30d26900c6294161a1dfe03e5c7c9c31f74aa1b2cec9f SHA512 e7324f98ac8609c1ce7ed957d0ee0280d177e9a6d369cc3bdb2cc8bde7f5e79d8f19b53c6b19fdfc732c9f84e4cd7dffa9c2af3cc004b3b5dbe703d73ce64009
DIST hypothesis-python-5.36.1.tar.gz 9086877 BLAKE2B 4b71daa1e9417d8249364292ca1dcbdbb31d041e2f5627776bb2d2d4493be82c85201d000e187e5cc445c79612f5918a5ac71a2787bbc0c21eff83d4c27b0dc3 SHA512 97d0446ba5660c189e60b47b8f782818525fcc1c5c1d64eec997b85d5ae47fc7d52771439b5c249002380ffe7d95696728f81efe513993ff90c8e192e2ceca8d
DIST hypothesis-python-5.36.2.tar.gz 9088227 BLAKE2B 578c28d045f3b3f288d43765d556f1e7bbde661684b71f6379df3eba516d8ece86f31a38a414e676532f6ecb8a1ee69ac77d207a8637eaef8b9a86584d3292eb SHA512 d6792d5b9f60aea6181018c69eaa12982ef0ab353bff3f46bc987a4633a15b655ed04ee8ae3aca7dbd9e23cf5f85e4a95e455082f4035e246342b72e2dafe258
+DIST hypothesis-python-5.37.0.tar.gz 9091454 BLAKE2B 2e51479f872dca6834d6cf8c2815e20cdb53c8968c3f5e5f6144a34c040e7dce9627c578ee072b21252b64af0507f361e4d5dfd3b65f8eb1abef9bfdac6d49ea SHA512 66e6f7a8ae11e9a8c8da79aa433d151733e07038ea37f211773972596bedaa227e8492fe7b9f363ea92ffcfd8c3e5a0a5364e04be22aab010a20544d3abcc93a
diff --git a/dev-python/hypothesis/hypothesis-5.37.0.ebuild b/dev-python/hypothesis/hypothesis-5.37.0.ebuild
new file mode 100644
index 000000000000..b817839fd0ac
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.37.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}