summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:03:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:12 +0200
commit4ea59ebe7a5dda4644aae71da0bb6f9c3377956f (patch)
tree148d7bc1317ccd036a4565217a1cb149b859cd3c /dev-python/hypothesis
parentmedia-gfx/solvespace: Maintainer retired (diff)
downloadgentoo-4ea59ebe7a5dda4644aae71da0bb6f9c3377956f.tar.gz
gentoo-4ea59ebe7a5dda4644aae71da0bb6f9c3377956f.tar.bz2
gentoo-4ea59ebe7a5dda4644aae71da0bb6f9c3377956f.zip
dev-python/hypothesis: Bump to 6.42.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.42.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 61e13c0135cf..5cd4f3495d11 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-python-6.39.6.tar.gz 9183382 BLAKE2B c1112dc11d9129c7685eccac563232c978fcb470b0537e468b802ecf1f758af8dfce323514f923605662e720d0d54f525e5aac3e871407255f5f0732856748fe SHA512 985645265e9644bd2731a08ab942984fae5cb35e04e27e60450bfcf237c375dae1f2d3bf3694031a452866669ae2e19a05085ce9e35630965938c066b265595a
DIST hypothesis-python-6.42.0.tar.gz 9186585 BLAKE2B dd08082ef466c91999a6bfa6dfc8386f773182f3e74cc471f6f09bf3c595871aea6508ea2ede4a1375b7ec1e0ba4169a7577c41c6ea97b578233ed64a36b4975 SHA512 fdd6c095aba72660b7cbf4e5200a3500019fef69f45c6a8f40a93815b6bce23c40404af16dba4309400917307485c378b3a12f3eea58d99ce8da68b397a69390
DIST hypothesis-python-6.42.2.tar.gz 9187457 BLAKE2B ee191bed48db8984a1adb14fb655f0d03e76934eeec3004842567de904508dd5e0a565c14d81b018d55ca18827b03e14a54ae520110c5960a6d048690d17a5f8 SHA512 1c82e5d010cccc54c7c4a05f12ac33eae0d53fdb1d4ed68313907c390fb4c1e58d2afb57816fc8f0f7facacaca0fd6eab90e513ba2dc0b47fb73adb19e1f2a8a
+DIST hypothesis-python-6.42.3.tar.gz 9187948 BLAKE2B 3303cea4e8f2776f14defd88dcc2578f11e30bd5842a2cddf96478e31505d38f801a92e031e76070684befb2a9d63713f44b73eea7152e0bdc6cc0d16e25c08c SHA512 869e81b46da7786cc4ca981da56c916922a73fd129dc1f156d062343e40a9b74888bdda17ef2c95e6c3102dc762f7cf587d1aad4ba3b8138060990d2987a0bd1
diff --git a/dev-python/hypothesis/hypothesis-6.42.3.ebuild b/dev-python/hypothesis/hypothesis-6.42.3.ebuild
new file mode 100644
index 000000000000..7eae997f3fdb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.42.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}