summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-12 08:24:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-12 11:11:33 +0200
commit731bf9304fd34657fbdbb1f8e3b4653bcc20aa16 (patch)
treefda9faaf4c36ec73e20f44680b88eb8b47cab79d /dev-python/hypothesis
parentdev-lang/scala-bin: removed obsolete 2.13.1-r1 (diff)
downloadgentoo-731bf9304fd34657fbdbb1f8e3b4653bcc20aa16.tar.gz
gentoo-731bf9304fd34657fbdbb1f8e3b4653bcc20aa16.tar.bz2
gentoo-731bf9304fd34657fbdbb1f8e3b4653bcc20aa16.zip
dev-python/hypothesis: Bump to 6.14.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.14.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 25778e7dfb3a..ddb7cc423a3a 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.10.1.tar.gz 9126246 BLAKE2B cc8cb3436d1de5d3d65a13cb5ed
DIST hypothesis-python-6.13.14.tar.gz 9134690 BLAKE2B 821fa0baa47dd896fc5ec61d0a96fec3da225dbc35306e6cf684641262c9ff0b714ca95aff69daca4bda551033a67d90b411f0cc2abff8edd41e5d749939344f SHA512 74397fd77e6e70df918e0fa605180e2bfd509fb26ef8b4a86020524611a315950073c3babd65bb2d2ff65d39e027bc52da88c0125f422cc2493076398e733853
DIST hypothesis-python-6.14.0.tar.gz 9135056 BLAKE2B 47d1efcee5e1c4037f1a20f08e3bc873fc143a2182bbde07e897812622c4d68923f78ac356bd97ef541566a27a874705eb2438747daaebe84f95fc2a2262bac1 SHA512 f7821449d3bf7f3656b52dad09027e40ea4af1779fcc7c0b995dac55843953fdab3f2ba69eb1b8de8258616f49cf8e5098c6a222d01071916c6f0c9fe184c80b
DIST hypothesis-python-6.14.1.tar.gz 9135154 BLAKE2B 0fa62cf4b512acf433a94edd14b2bc4c2c86cdbcc95e4a2760a1914e85f1149d9a5db6b22222c4954d2db109d3bff877ca0e5e8ec6842ff5b3c794a211ea9b57 SHA512 b84776e2bfff130c4db7582defbe9bc55183d624b45defffebdc954ca8e1dda1dec78f921e1bc7839a1167c37bce693711cd500da547dc6f2a8fa610c0bd3540
+DIST hypothesis-python-6.14.2.tar.gz 9135496 BLAKE2B f77f0668c4d0c2f5a952e06a40ae7898631804d3406c9711eb30a4e5a11e73ba2772be3cb437aacea2a75cd65f688a2485b98885c19cf743020900b0cf70f08c SHA512 e495e1c471fd4b185e23326700e85bf90635fcc8bf316c758c3285803ff0f7ad0269351b3a7631033495bb6498a8f19cb8661c55248ec5e14ff2a09e0c3af3c1
diff --git a/dev-python/hypothesis/hypothesis-6.14.2.ebuild b/dev-python/hypothesis/hypothesis-6.14.2.ebuild
new file mode 100644
index 000000000000..536affb7ae13
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.14.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}