summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 10:31:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 11:22:01 +0300
commit75fe2da083b7fab1a4efe5fad5f093f736c421cc (patch)
treec74480106078b4c1b3f4fcc124f1fa20c848f541 /dev-python/hypothesis
parentmedia-radio/unixcw: Look for ncurses lib during ./configure (diff)
downloadgentoo-75fe2da083b7fab1a4efe5fad5f093f736c421cc.tar.gz
gentoo-75fe2da083b7fab1a4efe5fad5f093f736c421cc.tar.bz2
gentoo-75fe2da083b7fab1a4efe5fad5f093f736c421cc.zip
dev-python/hypothesis: add 6.43.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.43.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 2724ee9d058a..caeab0c831cf 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.42.0.tar.gz 9186585 BLAKE2B dd08082ef466c91999a6bfa6dfc
DIST hypothesis-python-6.42.2.tar.gz 9187457 BLAKE2B ee191bed48db8984a1adb14fb655f0d03e76934eeec3004842567de904508dd5e0a565c14d81b018d55ca18827b03e14a54ae520110c5960a6d048690d17a5f8 SHA512 1c82e5d010cccc54c7c4a05f12ac33eae0d53fdb1d4ed68313907c390fb4c1e58d2afb57816fc8f0f7facacaca0fd6eab90e513ba2dc0b47fb73adb19e1f2a8a
DIST hypothesis-python-6.42.3.tar.gz 9187948 BLAKE2B 3303cea4e8f2776f14defd88dcc2578f11e30bd5842a2cddf96478e31505d38f801a92e031e76070684befb2a9d63713f44b73eea7152e0bdc6cc0d16e25c08c SHA512 869e81b46da7786cc4ca981da56c916922a73fd129dc1f156d062343e40a9b74888bdda17ef2c95e6c3102dc762f7cf587d1aad4ba3b8138060990d2987a0bd1
DIST hypothesis-python-6.43.0.tar.gz 9188330 BLAKE2B db237962b3c16c223fb49fff4c0c2e175f1969ce01c4ded3be3bcad0ff78c928f109016da58a4e9512e0d8fc3ea5ce9836732d00c74acc3ecd185ca1030849c1 SHA512 c1c3bda72cbe4f29be957d21682be1d1973f74afdf4adf95f388f05e4230781b16fb0004720620368b9aec4aa0623c4f79b7f3df16c37fbe9e812bb70a065af1
+DIST hypothesis-python-6.43.1.tar.gz 9188557 BLAKE2B 4dd3108c6162fb5b2a8f283e5499468b6a7ba3edb45cf6886d15cde5b6ee2ca6402c372d65f0576c4bba488d1e99f501bd61e8c26c0d887f716542287fe80a32 SHA512 9d01d4fd14d44445cc88e7eac28b2ce4555488fc87eccbb7739d97e23c42f608891532c17ef15c399d515f4b1856541c84f205630b3f5ba30ba7427774fcf2c1
diff --git a/dev-python/hypothesis/hypothesis-6.43.1.ebuild b/dev-python/hypothesis/hypothesis-6.43.1.ebuild
new file mode 100644
index 000000000000..7eae997f3fdb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.43.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}