summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-23 22:22:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-23 22:28:21 +0300
commit7f874d6e590b94af91aa8bbc1c5daafe9187029b (patch)
tree3e95cd96d7c9f0bf34d0fdef371df4abad622676 /dev-python/hypothesis
parentdev-python/pandas: add 1.4.3 (diff)
downloadgentoo-7f874d6e590b94af91aa8bbc1c5daafe9187029b.tar.gz
gentoo-7f874d6e590b94af91aa8bbc1c5daafe9187029b.tar.bz2
gentoo-7f874d6e590b94af91aa8bbc1c5daafe9187029b.zip
dev-python/hypothesis: add 6.47.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.47.4.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e041fb85ae87..adc57809455b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,4 +2,5 @@ DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38b
DIST hypothesis-hypothesis-python-6.47.1.gh.tar.gz 9314265 BLAKE2B c2ad0120ab2cbd565f73d472f0a5a87e4b51ff9cf7c08d75dbc54223ad9fe60ed475577ca7dced64ab02d4cc1ee5d30525677c4acfe720af8251f804e72a3b00 SHA512 1aea9f949242d3a273584cd92e1829654d6ce385efcd631b412374f1f9252d3b759b8e216aaa9a49e26e0c3b12673348eac79d0189881f6a811f11daf14b0873
DIST hypothesis-hypothesis-python-6.47.2.gh.tar.gz 9314053 BLAKE2B df607e7d81a280d916cc3946c71f6b2a6c7004263069e83d2647222730d11276b6c246fedbb07c5a4f3c526df38d6ea5c7999bdb416f0c86b0877d0231418c73 SHA512 b58835fac221353ea9beff227dda81f7776e2b50f6a765e536c83bea129d5c5a862551423d9df5abbc0cf294b358c6c537c62add69b3d5a1f38b22e179d2f83c
DIST hypothesis-hypothesis-python-6.47.3.gh.tar.gz 9314739 BLAKE2B 282b012e020fc6494b628ba629c576f604db831c219878ab92539fbd1d980f3363e490ef35f888b68902661dd82e682393641d13a882c1177d8570ec232b217a SHA512 c7231ff06ae5846f718e76c48ed4bb8a1fc0f9aff80c7ddd1ff0ead219eb93dcc7f9d5c5e591390661e81a33bcac79773ea620cfe3f246210114635f0c089144
+DIST hypothesis-hypothesis-python-6.47.4.gh.tar.gz 9314838 BLAKE2B 183048d7d784f8e64bcac1f5bb53b6b9f945b38d555aebd84d0966bcf64178e952f767dcf63122d9b3e8d41d79034b4b11074335e5dbb7575b5f78e152d05c25 SHA512 17a7388ac03ea9029bc5a90f24aa85c3f825bd04ceee963ff7f144ff675b0465afdd22edc5608931f1fd60e83c59d10be24dd74ed64015f942c3f09956b652d7
DIST hypothesis-python-6.46.9.tar.gz 9311955 BLAKE2B f8cf7e216650401ea8a9b427311d10bc65a21b79eb231864c4ff429baea4600f8d84b05e4b94120551ebe17f1b4b99a65e76157efe9d0a133ad68c22b1c46452 SHA512 e4fed5210ba11977958d4d14f9fb32427b812ea7903f391bbf977ade7ae268770e846b0cd2193585f519a02681e4fabfead23eea5bcededaccc0e7a9857e98cf
diff --git a/dev-python/hypothesis/hypothesis-6.47.4.ebuild b/dev-python/hypothesis/hypothesis-6.47.4.ebuild
new file mode 100644
index 000000000000..357dfa3b5ba6
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.47.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}