summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-28 11:00:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-28 12:14:26 +0200
commit8d3ec07ddfb04140e0b987885e0e13e88784409c (patch)
treefcce5485ff7fa99624d8909f27c2e1ed6b7744a1 /dev-python/hypothesis
parentdev-python/tldextract: Remove old (diff)
downloadgentoo-8d3ec07ddfb04140e0b987885e0e13e88784409c.tar.gz
gentoo-8d3ec07ddfb04140e0b987885e0e13e88784409c.tar.bz2
gentoo-8d3ec07ddfb04140e0b987885e0e13e88784409c.zip
dev-python/hypothesis: Bump to 6.39.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.39.6.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 3426ae451ea2..e4ea9ee9b846 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.38.0.tar.gz 9180960 BLAKE2B a62cb0cb31cfe4ece8ee829207b
DIST hypothesis-python-6.39.3.tar.gz 9182758 BLAKE2B 3641e5a9fd7e3e3e9f6432fa5bd5b8f6e4508fd840c781a65f11e8e99cee40dbd343bb17c37c60a4aabff00d5faca98a3a49b756eb754763ffc26a63a8450b38 SHA512 6dcbecdbd564aced4b0e14608a226d71adccaccfd54a3b9029f85a3e616372b7422f97029b5254bf1b08e44f74c714d65c1cb5fc21b6a0e0bdcedff2cc539ed2
DIST hypothesis-python-6.39.4.tar.gz 9182794 BLAKE2B 16c1867e2ea4dc08d6bb31aee14ec4c8fc7c7e21e57723d69184b227c1b2081e7f03a7d1f3a4975c485cbfc6011cb832de761874bddcfef716775a5bdd933927 SHA512 100e0b591980280b8a674e0c596fee65eee0428e0f116045b65f22a3bf2c114ff7068eac0b59764bbf5dc02b67711ca105fb655b705cbba7c1932cbbfc7da670
DIST hypothesis-python-6.39.5.tar.gz 9182972 BLAKE2B ecd92b759f574d2abed5310815c603adb2585e9a724532feea2fe1818c1693eabd3523ecda57c42b5e714684c53e80bce437156b49a7a23e5d0a87ef103d367f SHA512 da6ebb225a58b177870f9848ad44eb71af6c9a502ffa104ba023a24139b427b647c33b622063bd1c6050b5922c5a17ef0cbcff64dc85e5a9379b9503738dabd8
+DIST hypothesis-python-6.39.6.tar.gz 9183382 BLAKE2B c1112dc11d9129c7685eccac563232c978fcb470b0537e468b802ecf1f758af8dfce323514f923605662e720d0d54f525e5aac3e871407255f5f0732856748fe SHA512 985645265e9644bd2731a08ab942984fae5cb35e04e27e60450bfcf237c375dae1f2d3bf3694031a452866669ae2e19a05085ce9e35630965938c066b265595a
diff --git a/dev-python/hypothesis/hypothesis-6.39.6.ebuild b/dev-python/hypothesis/hypothesis-6.39.6.ebuild
new file mode 100644
index 000000000000..1bf4b6813bee
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.39.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}