summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 19:30:49 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:25:58 +0200
commit9222241744a35220e4607d6062724bb9d0bb5989 (patch)
tree79482f00fa75ae70383d65d5661d4b8cc7d3885e /dev-python/hypothesis
parentdev-python/python-openstackclient: add 5.8.0 (diff)
downloadgentoo-9222241744a35220e4607d6062724bb9d0bb5989.tar.gz
gentoo-9222241744a35220e4607d6062724bb9d0bb5989.tar.bz2
gentoo-9222241744a35220e4607d6062724bb9d0bb5989.zip
dev-python/hypothesis: add 6.39.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.39.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 49a2ba4bfbd5..249c396da713 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-6.37.0.tar.gz 9179770 BLAKE2B 914968515c65b52cfa7fd4908c7
DIST hypothesis-python-6.37.1.tar.gz 9179835 BLAKE2B 316b4bd4143d8bd403bac2fcc713c49c0a1f5f713d78335845f77c7ac9dac852cce367ac618999265ab4c68e848037920b2be6e18f68bd1f3d6982b1e7f5e297 SHA512 7b5e961339672cf853d181f4a3963ab753fe0bd7af599247996629de2b8e62159b3cfe6ce8663b2499e2e4e2dbdcc99fc99c5a582a73102c5637e82ce4624c64
DIST hypothesis-python-6.37.2.tar.gz 9179951 BLAKE2B 0178beee31353d94454ce289d9214153b394612f28cec52e906456cda6419b7b427213ac46ff423c1f6d853e82d737b2f9f57ae89c20481cabde2bc523a87c18 SHA512 659ddce542e26047b0dceb764588c0ffa20a096f44b742514105d4f6f933042ee29fb84897863112fabf19b83de9d357714f252f5adeb8d0557788c62b71c6e2
DIST hypothesis-python-6.38.0.tar.gz 9180960 BLAKE2B a62cb0cb31cfe4ece8ee829207befb729aebf2be802c57b398547c87ecbd4769955c5c2919a0eb653d41cc3f4998c5326fdb184b6409d5fcb632c037df6a542f SHA512 2d57b783a71a905470ca088ebd91c0ea96be1bd76648d30d52b0b43914844712bbf3eaad54d66607b149a1238bb9a0258f920a6e262e54bed5cef36e3ca227e1
+DIST hypothesis-python-6.39.3.tar.gz 9182758 BLAKE2B 3641e5a9fd7e3e3e9f6432fa5bd5b8f6e4508fd840c781a65f11e8e99cee40dbd343bb17c37c60a4aabff00d5faca98a3a49b756eb754763ffc26a63a8450b38 SHA512 6dcbecdbd564aced4b0e14608a226d71adccaccfd54a3b9029f85a3e616372b7422f97029b5254bf1b08e44f74c714d65c1cb5fc21b6a0e0bdcedff2cc539ed2
diff --git a/dev-python/hypothesis/hypothesis-6.39.3.ebuild b/dev-python/hypothesis/hypothesis-6.39.3.ebuild
new file mode 100644
index 000000000000..e070fa008ff0
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.39.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}