summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-18 12:09:47 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-18 12:09:59 +0200
commitb84b2222192a08a470c0ad1117a76acac47f00ef (patch)
treeccbfad7e86c4ca19e25919afe967b91acfaa270a /dev-python/hypothesis
parentmedia-libs/opus: Removed old. (diff)
downloadgentoo-b84b2222192a08a470c0ad1117a76acac47f00ef.tar.gz
gentoo-b84b2222192a08a470c0ad1117a76acac47f00ef.tar.bz2
gentoo-b84b2222192a08a470c0ad1117a76acac47f00ef.zip
dev-python/hypothesis: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.4.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f94c69f37bdb..89ab41530287 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-2.0.0.tar.gz 76894 SHA256 b9bfe9884dcca0268157f015992e6cdd404d16
DIST hypothesis-3.0.0.tar.gz 59543 SHA256 a273d62efe25e004552ee4c505290992870e1d831f2ec3399d8b8811f1eba935 SHA512 ce7ee8ad6c0a4474ffddac549a1f7025eaf9393ab66154517948f7a420cdb1c18b379a52afca1901fca7ed46f7c44acde8e96632e863923a45a4782860ca6fcd WHIRLPOOL 97ffc82a69e6a3c5e2414936347328eb6d3f3994eaf41fea93314ba443362ced9906803f3195d4b68310696ac6a4e69f0035c9486ce3a6b2467dce50dce450ca
DIST hypothesis-3.1.0.tar.gz 69051 SHA256 7cad9ab1caeb3eeda4359536f3d9b17ab3e97160f259862c847a933a55c2d863 SHA512 c258c450960cf8742a54e2c5fb58609f4c529b5ba2cf0fb48966b7a7678223bf2f52919aa4f05690c7e7e7527a4e008fad1ca5ec18b27f3ee5d6546b26881706 WHIRLPOOL d8de4a9f48a16db39d5281419664acfdcddeb833b52018fa00e0078f7d9848d3b93a9dd0455e61ee3aacf9c8868e7b85cfb9a35bb09b97fcccebaccc8c8707e5
DIST hypothesis-3.4.0.tar.gz 71148 SHA256 b9723e6cd0f1355e5f0db0c255b903fafd19d91506d72623231937cf75416610 SHA512 b7706649facfa85ba60dbd6aa3c215ef8f7018b37eed1a6d2fe7ba323c1da6b0c3fb03ace78f58a9ce589bb3ddf5bcc560667651e1d7e6c67d920bf71a7b54e7 WHIRLPOOL fa2c78fff001759e15063be2e40933c203ee94ddde9dbd078d0461b0b36f24204110a9f9d65d07e1ed0330a489c7fa03e3bfab5e725be0c001c818dc9050e4e3
+DIST hypothesis-3.4.2.tar.gz 71270 SHA256 87a6b96670d52d9c30fff1342adec178822cd472775588d998bd860c05409688 SHA512 355815a11c57448a175a984d1ad6e87dcd9cc954acf312bfeff4ec499678166be6b9751173307748ff8b2d325b502cd31151e883e2a52f2d51a0395436bdb039 WHIRLPOOL 839bdc774f3889b0243119a81a9caa9eb29918dbf79ed7f5d7a1d15bab2e2ad6cfcd41948ab8b249c7bfecec3271aab99724b2eb2bde340136d9d9253f1fdeef
diff --git a/dev-python/hypothesis/hypothesis-3.4.2.ebuild b/dev-python/hypothesis/hypothesis-3.4.2.ebuild
new file mode 100644
index 000000000000..839322f72dcd
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}