summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 08:50:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 10:13:36 +0200
commitbbc6ad6f053a35224a722adae70852189b65122a (patch)
tree156a93ea0202070224ed41aa7db19520f0baa7ef /dev-python/hypothesis
parentdev-python/markdown2: Bump to 2.4.3 (diff)
downloadgentoo-bbc6ad6f053a35224a722adae70852189b65122a.tar.gz
gentoo-bbc6ad6f053a35224a722adae70852189b65122a.tar.bz2
gentoo-bbc6ad6f053a35224a722adae70852189b65122a.zip
dev-python/hypothesis: Bump to 6.45.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.45.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 94e19d570f31..e180fae18390 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.42.3.tar.gz 9187948 BLAKE2B 3303cea4e8f2776f14defd88dcc
DIST hypothesis-python-6.43.3.tar.gz 9189636 BLAKE2B d47e4b5f3016e32c8ba547eca7f3b6513609d6a84cf1f1b8db5e14282e75cf4ee1778fba1dcf801fac135a1ebfef2ce5f9306bd9be4c33f02b5f05d1690abba2 SHA512 1988efc630b63a2373f25813bd066a1da8576416a167d487f1b262825c49864ab622e84a6189d5016f8ca28b37819d5f035bc11779f906a447baf2f957fedfcc
DIST hypothesis-python-6.44.0.tar.gz 9189825 BLAKE2B f6688f55a920b0dc65beab54d715c98869bf70d29ed4044f4ad15c88cb9b60cc5dee834f9d218e15d6cc9e02a8b25114660af2578ab07c9a353124cb95611e22 SHA512 8642d078f2e7e232baa100075dac530e4e7c358f8ea7bdb5fd1f3d29ceb291a1a00abfdd25596669010c230893c7d6fc29cc54be42340aabc2481a612e616684
DIST hypothesis-python-6.45.0.tar.gz 9191348 BLAKE2B e607b21f0e24daec57b19be5e8c1b77c9d78abb724cd5b89dc7dff1351a066387f990d0d92bded39ccb4da4368c3b827a6f3117a24c251d8955be98d8338ba3a SHA512 01e4aea5ce71c476fbee52182ff07529126744eb8bb603175370d33d2e1ce49a367ef2c0ec7abf879ed2bfa25a31e1b2136e2b79bc68d4a4c200cc3159583c6c
+DIST hypothesis-python-6.45.1.tar.gz 9190980 BLAKE2B 61365d27603383cb76d62a0f0f4ca01ac09c779d90b8f028709fedb20dccabb8bb3d452d7bf87926a8bc30c334387378e1cc8e2b42c9bfa8834577e01b34d635 SHA512 a68eaf4b5012735027aba70eae8c244747a676e345b5ab6c6f7e08cab58ce3330410eba5eaa1ded89d1e15386bf644d3df9012b382d675e967781cd7b762fb21
diff --git a/dev-python/hypothesis/hypothesis-6.45.1.ebuild b/dev-python/hypothesis/hypothesis-6.45.1.ebuild
new file mode 100644
index 000000000000..7eae997f3fdb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.45.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}