summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-18 09:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-18 10:19:04 +0200
commitbc27defb2d6928d0ae5a87fc461bab612c38a115 (patch)
tree48b5d0b381ac692d2e23f7a05da84ff81f138bf1 /dev-python/hypothesis
parentdev-java/icedtea-sound: drop 1.0.1 (diff)
downloadgentoo-bc27defb2d6928d0ae5a87fc461bab612c38a115.tar.gz
gentoo-bc27defb2d6928d0ae5a87fc461bab612c38a115.tar.bz2
gentoo-bc27defb2d6928d0ae5a87fc461bab612c38a115.zip
dev-python/hypothesis: Bump to 6.43.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.43.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f29c979ad3f8..7bd9bc7329cf 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-6.42.3.tar.gz 9187948 BLAKE2B 3303cea4e8f2776f14defd88dcc
DIST hypothesis-python-6.43.0.tar.gz 9188330 BLAKE2B db237962b3c16c223fb49fff4c0c2e175f1969ce01c4ded3be3bcad0ff78c928f109016da58a4e9512e0d8fc3ea5ce9836732d00c74acc3ecd185ca1030849c1 SHA512 c1c3bda72cbe4f29be957d21682be1d1973f74afdf4adf95f388f05e4230781b16fb0004720620368b9aec4aa0623c4f79b7f3df16c37fbe9e812bb70a065af1
DIST hypothesis-python-6.43.1.tar.gz 9188557 BLAKE2B 4dd3108c6162fb5b2a8f283e5499468b6a7ba3edb45cf6886d15cde5b6ee2ca6402c372d65f0576c4bba488d1e99f501bd61e8c26c0d887f716542287fe80a32 SHA512 9d01d4fd14d44445cc88e7eac28b2ce4555488fc87eccbb7739d97e23c42f608891532c17ef15c399d515f4b1856541c84f205630b3f5ba30ba7427774fcf2c1
DIST hypothesis-python-6.43.2.tar.gz 9189222 BLAKE2B 4af4dc59198878b08973366483e6be9d23c96942e83e8d19e1a77b26ba532bdc114224de1daf23b0162cef0844b240bb12da0ffdb4d86e13b448e768cdeb6485 SHA512 903857aa730615067309557e6d03ae083a05bf0d53285c6a48d8269239e88e0a261b711477a7de5349b2606e53ece8cf50679f0a0c58accdd64e18d1cd3f2b9d
+DIST hypothesis-python-6.43.3.tar.gz 9189636 BLAKE2B d47e4b5f3016e32c8ba547eca7f3b6513609d6a84cf1f1b8db5e14282e75cf4ee1778fba1dcf801fac135a1ebfef2ce5f9306bd9be4c33f02b5f05d1690abba2 SHA512 1988efc630b63a2373f25813bd066a1da8576416a167d487f1b262825c49864ab622e84a6189d5016f8ca28b37819d5f035bc11779f906a447baf2f957fedfcc
diff --git a/dev-python/hypothesis/hypothesis-6.43.3.ebuild b/dev-python/hypothesis/hypothesis-6.43.3.ebuild
new file mode 100644
index 000000000000..7eae997f3fdb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.43.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}