summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-13 18:54:39 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-13 18:54:39 +0100
commitbc4d7ef10478fe120d40749b1842d7c6bbf26a2d (patch)
tree4f6f03ef1b561351aa642f944f7cd8070fff7fa9 /dev-python/hypothesis
parentdev-ruby/extlib: Remove ruby19 (diff)
downloadgentoo-bc4d7ef10478fe120d40749b1842d7c6bbf26a2d.tar.gz
gentoo-bc4d7ef10478fe120d40749b1842d7c6bbf26a2d.tar.bz2
gentoo-bc4d7ef10478fe120d40749b1842d7c6bbf26a2d.zip
dev-python/hypothesis: Bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.1.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 159cfb51d0bb..5331ed06f4cc 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-1.12.0.tar.gz 76679 SHA256 5e90a8fa249de9c492b4fa573f6f2dc489de9
DIST hypothesis-1.19.0.tar.gz 86227 SHA256 0e977a3492f5488ed9dd4a872cefae0934ad4ccd0229a6c483ef5ca0aaaddd6d SHA512 3b2cd671498bd0bc88c93b2753f35b02f737533dd8dbc786420a37a417d145e4f1c579741966394f85b7df4939e61f77315e6158b29e22f9bde07d31e161e009 WHIRLPOOL 52b444e6e3fa0c514ebb9816cd489b2441b213581e241f76ab5aa5c410ca08bedef92f0b608c32c421f74ba84a0e26850a2aaf9f2d9f7229aa176d9e501175a0
DIST hypothesis-2.0.0.tar.gz 76894 SHA256 b9bfe9884dcca0268157f015992e6cdd404d16dab18c2df403c458b6afab46d1 SHA512 7a5f5931b8f427a1cef8ef1735d995a6f5d854acec163bdedf369eb166ed289e024d70c6e5fd556bf8b1e0844d600460f97906cd43f70400995c7919bce20ab3 WHIRLPOOL c669c831c24c2dafeeead8b3e0a24bdfe69017bbf7eb94936b0ce22feac502b3ccdade37cff4b6141d97d79500578b6ef080d0f8fbe8e1c54aca7bfe4db40c42
DIST hypothesis-3.0.0.tar.gz 59543 SHA256 a273d62efe25e004552ee4c505290992870e1d831f2ec3399d8b8811f1eba935 SHA512 ce7ee8ad6c0a4474ffddac549a1f7025eaf9393ab66154517948f7a420cdb1c18b379a52afca1901fca7ed46f7c44acde8e96632e863923a45a4782860ca6fcd WHIRLPOOL 97ffc82a69e6a3c5e2414936347328eb6d3f3994eaf41fea93314ba443362ced9906803f3195d4b68310696ac6a4e69f0035c9486ce3a6b2467dce50dce450ca
+DIST hypothesis-3.1.0.tar.gz 69051 SHA256 7cad9ab1caeb3eeda4359536f3d9b17ab3e97160f259862c847a933a55c2d863 SHA512 c258c450960cf8742a54e2c5fb58609f4c529b5ba2cf0fb48966b7a7678223bf2f52919aa4f05690c7e7e7527a4e008fad1ca5ec18b27f3ee5d6546b26881706 WHIRLPOOL d8de4a9f48a16db39d5281419664acfdcddeb833b52018fa00e0078f7d9848d3b93a9dd0455e61ee3aacf9c8868e7b85cfb9a35bb09b97fcccebaccc8c8707e5
diff --git a/dev-python/hypothesis/hypothesis-3.1.0.ebuild b/dev-python/hypothesis/hypothesis-3.1.0.ebuild
new file mode 100644
index 000000000000..839322f72dcd
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}