summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 08:23:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 08:41:33 +0200
commitc5fafed60bc7e53dd01cf948ce96069baf955a0e (patch)
treea82e16c18d2af68e56a914d185e08313096f3d57 /dev-python/hypothesis
parentdev-ruby/ox: stabilize 2.14.10 for amd64 (diff)
downloadgentoo-c5fafed60bc7e53dd01cf948ce96069baf955a0e.tar.gz
gentoo-c5fafed60bc7e53dd01cf948ce96069baf955a0e.tar.bz2
gentoo-c5fafed60bc7e53dd01cf948ce96069baf955a0e.zip
dev-python/hypothesis: Bump to 6.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index ebc2baafb85f..80538bfddb1d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.44.0.tar.gz 9189825 BLAKE2B f6688f55a920b0dc65beab54d71
DIST hypothesis-python-6.45.0.tar.gz 9191348 BLAKE2B e607b21f0e24daec57b19be5e8c1b77c9d78abb724cd5b89dc7dff1351a066387f990d0d92bded39ccb4da4368c3b827a6f3117a24c251d8955be98d8338ba3a SHA512 01e4aea5ce71c476fbee52182ff07529126744eb8bb603175370d33d2e1ce49a367ef2c0ec7abf879ed2bfa25a31e1b2136e2b79bc68d4a4c200cc3159583c6c
DIST hypothesis-python-6.45.1.tar.gz 9190980 BLAKE2B 61365d27603383cb76d62a0f0f4ca01ac09c779d90b8f028709fedb20dccabb8bb3d452d7bf87926a8bc30c334387378e1cc8e2b42c9bfa8834577e01b34d635 SHA512 a68eaf4b5012735027aba70eae8c244747a676e345b5ab6c6f7e08cab58ce3330410eba5eaa1ded89d1e15386bf644d3df9012b382d675e967781cd7b762fb21
DIST hypothesis-python-6.45.3.tar.gz 9191554 BLAKE2B 0fc07224be3c0f9f852d86c70540f616ea5f2b081e8e784ade4af105597146fd16c8c5245ca8e4fcf681847e4214b13da36dd88f81be4a24411e516b313f428a SHA512 f103e45de796d9c6374dd51e16d05e3aab472ad86d9f78dba810ab4a034893aac3aebf944af279d850f3138a6205c56c91c6e861673fb777228a9fb5d3a5a59c
+DIST hypothesis-python-6.46.0.tar.gz 9192054 BLAKE2B acfb6136b43f29b62ebd843a8c1437955f2f6681af16293f0f0a0fb651c0a69fb06c15b67fac8f9f73ad2459e0a5a0e4292e5dae1eb0a49e14760849a3af944f SHA512 5fcfd72d17a69e0dcd23a0d5633c15507017750dce61ae2be457151e4099ea7aea66b7d8b0aad98615453763935bb353197b094191dea78ece3ff297c89cf71f
diff --git a/dev-python/hypothesis/hypothesis-6.46.0.ebuild b/dev-python/hypothesis/hypothesis-6.46.0.ebuild
new file mode 100644
index 000000000000..5b35c96c0a4d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.46.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}