summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-13 22:06:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-13 22:31:11 +0200
commitcff30b96ecfb35949e542049c44b665244440157 (patch)
tree552ed29481779c297f0ed4452031dc2abdd7ff32 /dev-python/hypothesis
parentdev-python/django-otp: Bump to 1.1.0 (diff)
downloadgentoo-cff30b96ecfb35949e542049c44b665244440157.tar.gz
gentoo-cff30b96ecfb35949e542049c44b665244440157.tar.bz2
gentoo-cff30b96ecfb35949e542049c44b665244440157.zip
dev-python/hypothesis: Bump to 6.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.21.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index a340db8dfba2..d4b09c8c3371 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-python-6.19.0.tar.gz 9146087 BLAKE2B 11cf1e76735f2d57ee793c131a0
DIST hypothesis-python-6.20.0.tar.gz 9146238 BLAKE2B 88009c7369209f8781644a975587d757ecf83e9e84e650fd2f8e88b5e4e1d078dd0639e49a9055c4390c0aba96a661561ff5858bf628036d097c614b7d9fc45a SHA512 6c139c78b75c5b8408345d654e6d638f4f2b0f1567bcb05c430e396d3dbf40fde7e3f6a6af4eea75b2387d395e8ee2a5eb11eabd3183c4eff0a35979aed1bcba
DIST hypothesis-python-6.20.1.tar.gz 9146416 BLAKE2B ae3e10ffe2853009b8d698e0eae391e05632ba1a3d889dbfb498b8f46c18ec16477daefa9052dc6711f3239f9e83ffc7d52c6ad0c554492a00a55417b583afe7 SHA512 8d23bd0311cd8e81d7fd3851f4a72cc92bea4a07943475d8be9bac9dc9d5096f0d7d5e8ed8b14e64dbdb3c49b7d2c7ecc8d85dfe30d5e6f9f0ed96570ce4ddb0
DIST hypothesis-python-6.21.0.tar.gz 9162663 BLAKE2B a5a2fbb7b377e6cf769c3454ca89615551164e1b0dae24abee15191fcdff2eb1f01b9462c7aff68a7ea801477105bdfe5f6a33f098eb506325031d3511914ae5 SHA512 7d91d83580403da3afac0f4e0a72935c63d7da2ff28429423a3001b0a19a1b6216fe36eb526e91fe9e7f0cae481aa3f446695f7407ec2201c5f8abc6e3ea19a8
+DIST hypothesis-python-6.21.1.tar.gz 9162836 BLAKE2B af52db17d51801d03496036f14b9b1e79667de64b4d5df925bffe00f67e11fb652f0e027bf250d3f4286e113052b3413b75fcd6c8922702924ca0eb9c46849dd SHA512 4e9d994e1323ee90cd4555ae3f310bcf4661079b287e000a65fbda7771e02c265c387df3bbbd0425d54b342de4fb20632b6a35842bc7a66affbdda159048359b
diff --git a/dev-python/hypothesis/hypothesis-6.21.1.ebuild b/dev-python/hypothesis/hypothesis-6.21.1.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.21.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}