summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-07 22:15:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-07 22:15:59 +0300
commitd6bc4e6d2c5e094e39eb3de2e24d879c3d59ece4 (patch)
tree72d5b87257d4077f192829849cbf31af941bc041 /dev-python/hypothesis
parentdev-python/mkdocs-material: add 8.3.3 (diff)
downloadgentoo-d6bc4e6d2c5e094e39eb3de2e24d879c3d59ece4.tar.gz
gentoo-d6bc4e6d2c5e094e39eb3de2e24d879c3d59ece4.tar.bz2
gentoo-d6bc4e6d2c5e094e39eb3de2e24d879c3d59ece4.zip
dev-python/hypothesis: add 6.47.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.47.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1afa52ee5c62..ed6cf161d66a 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,4 +1,5 @@
DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
+DIST hypothesis-hypothesis-python-6.47.0.gh.tar.gz 9313488 BLAKE2B 2b778d5d6d43f12ee57e05af2c0914ed8b5468235be331ee80624069d64ffe7cce299dd70d1777a4139d3d2590f64dca8b0fa515039dd43cc13bda3dacb5b76d SHA512 4502add489e2fbee8bcced0f7f65ea1015a40c7811133bc9b0979c2e46749c477bc29889e0be2be1bbb240afe96867160c2991b531591ea1e72fdf9d759da6f0
DIST hypothesis-python-6.46.2.tar.gz 9305176 BLAKE2B 7d0abe4fc055eeb4660efbba9900b43209cc5ef1fd7b2362545e0d4145837cb7779cdf96c96cdd3770c1605ec8104818ece5cd012a90b164ab8ab63709d1c911 SHA512 207b4202aa36a28891c8051009ee6b8b6a8f0823840db7e4fc6840ebe6455060340f16f7e2e25bc5ad2adca1ff7fd8b58668ec2ca355b4579ec03aac616e786d
DIST hypothesis-python-6.46.3.tar.gz 9306685 BLAKE2B a26c08361a7a58d8de8d8458a73c5c3c57f04dd2008ab31e604f0addc18fb7a52a7f4a98318498b398cd1ac5d2d718fd722c4d17e0b6ef326e0457355fda7482 SHA512 d55c3c4a57d18aa7f6d876123b09bcab32d508f5aa40048f2db7f0cab3948ebb6fab5f12d291ae4740cdd1c61c2d612c1ce804028bb59914efc132404224d1ee
DIST hypothesis-python-6.46.7.tar.gz 9308855 BLAKE2B a26cd556bb56ff5a09987e7e4a9a46e966f26106376a4b5e481a933495f21c4a69dff0d68aa8d2006fc42794392eca35b4b68cb88e0d4695ecfe3bfe2098e9b6 SHA512 239343424df13db419bfc9057f9024ab8360cace07a0cf7d592744afa76fff54d5c30a0b7fecb41c642d034b2327feef7bec78840df25793727ce30be1aa7ef9
diff --git a/dev-python/hypothesis/hypothesis-6.47.0.ebuild b/dev-python/hypothesis/hypothesis-6.47.0.ebuild
new file mode 100644
index 000000000000..3c1dd06d14a6
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.47.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}