summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 21:55:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 22:26:43 +0200
commitd86fe3c1b432eb39b78231fb05bbddbdb55596a0 (patch)
treeca67881f9a01d7951650a6132acc1247db2d0f3d /dev-python/hypothesis
parentdev-python/django-mptt: Bump to 0.13.3 (diff)
downloadgentoo-d86fe3c1b432eb39b78231fb05bbddbdb55596a0.tar.gz
gentoo-d86fe3c1b432eb39b78231fb05bbddbdb55596a0.tar.bz2
gentoo-d86fe3c1b432eb39b78231fb05bbddbdb55596a0.zip
dev-python/hypothesis: Bump to 6.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.19.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c297fe28601d..e399ab95f5ab 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.14.5.tar.gz 9135819 BLAKE2B 2e42949f81024038b901231a844
DIST hypothesis-python-6.14.9.tar.gz 9138640 BLAKE2B 3cda0edace7b3a1c373bdd61267013874fe78ae18aa7fda02759ac451f7e576614a61c3ce1d588e24afe4333f61680d89eb30f6f055e41fee91312c791b1af5d SHA512 a32d4f09ae6a44354d136164a517ea53c653fccb3e21a39ac63df78ebdf695c887f13749d2f310ac67863b6645a85dca73ef0bfab077aefe0486e445f6a85dce
DIST hypothesis-python-6.17.4.tar.gz 9144209 BLAKE2B b110e355b34f386c51e9edeb2589bf11e5d0b574ee7e97437f9eba9ec7d8e823e68ad1e4f5911a1e78f3d5a316f59056301b0238c4b6a8cdcb21e46ea434686c SHA512 95eeadc1655d249008897035660af54f66e8ea78fea78d1069dbddb979505e003d1bdb971371769e90af4a7bc5f96ee0c42a6c14bc42e56677d4f89f39985d41
DIST hypothesis-python-6.18.0.tar.gz 9145660 BLAKE2B 6fb47aeb134363e50944d08f0658245d9cc5190260e56cc16c394499df0bcf3739fd69c22bcfce6f3b290a1ecd9bdc8ac6bfd7c5f2efd4b00694b81d7dba062d SHA512 069deaa91b7dc7244c8fccb046e384c60009365418dfb7f76ed75428446a731ec860613201d0657c2c8b3b29e4fce3c403a93aa082f48b072471f919b7a1af5a
+DIST hypothesis-python-6.19.0.tar.gz 9146087 BLAKE2B 11cf1e76735f2d57ee793c131a055c0e349bf7a39b072ac33914bcc371d44a607866ec617d2f955779fe99922f968b8da571fea87c45db72583e3ea2026000a5 SHA512 b641938c6f9b5603bb7b72ba1106da16bdcd0528de34317afdc4099bbfa1bfec90e76fbf14dc7cfc773fb02c3fa3b4bcfeea7f3788884cbefb51751f02879f9c
diff --git a/dev-python/hypothesis/hypothesis-6.19.0.ebuild b/dev-python/hypothesis/hypothesis-6.19.0.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.19.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}