summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:23:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:23:18 +0300
commitf419cc88e721c0fc62e989975e6e22311e09729e (patch)
tree576ee5a9b83405ff310e27a8b89c5d293020423c /dev-python/hypothesis
parentnet-libs/webkit-gtk: Stabilize 2.34.6 ppc, #833923 (diff)
downloadgentoo-f419cc88e721c0fc62e989975e6e22311e09729e.tar.gz
gentoo-f419cc88e721c0fc62e989975e6e22311e09729e.tar.bz2
gentoo-f419cc88e721c0fc62e989975e6e22311e09729e.zip
dev-python/hypothesis: add 6.40.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.40.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1ffacd52fb51..db0e900897b9 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.39.4.tar.gz 9182794 BLAKE2B 16c1867e2ea4dc08d6bb31aee14
DIST hypothesis-python-6.39.5.tar.gz 9182972 BLAKE2B ecd92b759f574d2abed5310815c603adb2585e9a724532feea2fe1818c1693eabd3523ecda57c42b5e714684c53e80bce437156b49a7a23e5d0a87ef103d367f SHA512 da6ebb225a58b177870f9848ad44eb71af6c9a502ffa104ba023a24139b427b647c33b622063bd1c6050b5922c5a17ef0cbcff64dc85e5a9379b9503738dabd8
DIST hypothesis-python-6.39.6.tar.gz 9183382 BLAKE2B c1112dc11d9129c7685eccac563232c978fcb470b0537e468b802ecf1f758af8dfce323514f923605662e720d0d54f525e5aac3e871407255f5f0732856748fe SHA512 985645265e9644bd2731a08ab942984fae5cb35e04e27e60450bfcf237c375dae1f2d3bf3694031a452866669ae2e19a05085ce9e35630965938c066b265595a
DIST hypothesis-python-6.40.0.tar.gz 9184563 BLAKE2B 7087baa8eed9849e639bc1d67e77a3426702e64e31252e893a19efb1457dd3c9994ed7459084b9c88f3574b89268369ee63bc1ed8dd6f0c257c0af50dc5a3eb1 SHA512 51b062b934c90137cb55fea58c639ebdbfdae21d0af8bf951add83b36c1286f959de47442219174fe80d0a98ffbe0c53cb9cd1b3908b63742c5d7662c84518e0
+DIST hypothesis-python-6.40.1.tar.gz 9184638 BLAKE2B bc1900b5328514f1f1f5753d9370229a30108e626400fa93aebcb43d33caa6301108b277ccd8356ef944f2d54387444f67efa4e041f553e40f889b233be03ed8 SHA512 9ae09a8a337fb2d4a94b83ecc02dc5c62759ca9c9043bdd2326084413ff3106c52a654c2c7a99b22fcef28909387ef0450207d0883cf15303c84f3a7f42987d9
diff --git a/dev-python/hypothesis/hypothesis-6.40.1.ebuild b/dev-python/hypothesis/hypothesis-6.40.1.ebuild
new file mode 100644
index 000000000000..1bf4b6813bee
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.40.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}