summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 08:33:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 09:13:32 +0200
commitf61c5a84a1548f51ce016c700a3f9d724956608e (patch)
tree36610e150fc315f4718cc0172a8c556972212c0c /dev-python/hypothesis
parentdev-python/puremagic: Bump to 1.13 (diff)
downloadgentoo-f61c5a84a1548f51ce016c700a3f9d724956608e.tar.gz
gentoo-f61c5a84a1548f51ce016c700a3f9d724956608e.tar.bz2
gentoo-f61c5a84a1548f51ce016c700a3f9d724956608e.zip
dev-python/hypothesis: Bump to 6.46.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index bb6d3226a1bb..7e83c194765e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-6.45.3.tar.gz 9191554 BLAKE2B 0fc07224be3c0f9f852d86c7054
DIST hypothesis-python-6.46.0.tar.gz 9192054 BLAKE2B acfb6136b43f29b62ebd843a8c1437955f2f6681af16293f0f0a0fb651c0a69fb06c15b67fac8f9f73ad2459e0a5a0e4292e5dae1eb0a49e14760849a3af944f SHA512 5fcfd72d17a69e0dcd23a0d5633c15507017750dce61ae2be457151e4099ea7aea66b7d8b0aad98615453763935bb353197b094191dea78ece3ff297c89cf71f
DIST hypothesis-python-6.46.1.tar.gz 9192240 BLAKE2B cb38e1f7fdc4a9586c3920f2d9270a9ad08a77eab52ba493e4ae4fb8ab17780b49f0e4f52004bc330021836a1470feffb96554757495259d34cf52f4ae2b264f SHA512 b273e6c77251544314babdc891e8c2f3f9098b97ba25cfa7eee960773e4508840c27af2b993daa00546cb269eb58d74b6bbfefef2d8869e2d202622983af520a
DIST hypothesis-python-6.46.2.tar.gz 9305176 BLAKE2B 7d0abe4fc055eeb4660efbba9900b43209cc5ef1fd7b2362545e0d4145837cb7779cdf96c96cdd3770c1605ec8104818ece5cd012a90b164ab8ab63709d1c911 SHA512 207b4202aa36a28891c8051009ee6b8b6a8f0823840db7e4fc6840ebe6455060340f16f7e2e25bc5ad2adca1ff7fd8b58668ec2ca355b4579ec03aac616e786d
+DIST hypothesis-python-6.46.3.tar.gz 9306685 BLAKE2B a26c08361a7a58d8de8d8458a73c5c3c57f04dd2008ab31e604f0addc18fb7a52a7f4a98318498b398cd1ac5d2d718fd722c4d17e0b6ef326e0457355fda7482 SHA512 d55c3c4a57d18aa7f6d876123b09bcab32d508f5aa40048f2db7f0cab3948ebb6fab5f12d291ae4740cdd1c61c2d612c1ce804028bb59914efc132404224d1ee
diff --git a/dev-python/hypothesis/hypothesis-6.46.3.ebuild b/dev-python/hypothesis/hypothesis-6.46.3.ebuild
new file mode 100644
index 000000000000..4d5a968020c8
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.46.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" python3.{8..10}; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}