summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-16 23:10:49 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-16 23:10:49 -0400
commit56c4533bede81709390b3671b3f8e9a6be8ee850 (patch)
tree71844e0c7e5e89b8993d2c1dda0f1b3ce172e7d0 /dev-python/idna/idna-2.7.ebuild
parentprofiles: adjust mask author email address (diff)
downloadgentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.tar.gz
gentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.tar.bz2
gentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.zip
dev-python/idna: version bump to 2.7
Diffstat (limited to 'dev-python/idna/idna-2.7.ebuild')
-rw-r--r--dev-python/idna/idna-2.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/idna/idna-2.7.ebuild b/dev-python/idna/idna-2.7.ebuild
new file mode 100644
index 000000000000..f57d72cfe473
--- /dev/null
+++ b/dev-python/idna/idna-2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}