summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-27 04:39:16 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-27 04:53:49 -0400
commitdcb9a2c832d3fc365cc6dfffa07c572999204201 (patch)
treebb9b7d3aba3ab25803ae931bbdacede6e95ae1a0 /dev-python/idna
parentdev-python/packaging: remove old (diff)
downloadgentoo-dcb9a2c832d3fc365cc6dfffa07c572999204201.tar.gz
gentoo-dcb9a2c832d3fc365cc6dfffa07c572999204201.tar.bz2
gentoo-dcb9a2c832d3fc365cc6dfffa07c572999204201.zip
dev-python/idna: version bump to 2.6
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-2.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 56453af378ed..2f36bbe77f14 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1,2 +1,3 @@
DIST idna-2.0.tar.gz 135150 SHA256 16199aad938b290f5be1057c0e1efc6546229391c23cea61ca940c115f7d3d3b SHA512 005f88e954f13ace584ced510752da58d1cb16ebfbeee10aeef5bec57b3c61a3a5d7ce0bb50deba6dc90b412607727bf94a95a785e91d6528cd8633961c142dc WHIRLPOOL d865420f1c5f648d12480af93a52e0b2d463064c34c57ce56022f6965c2e4f6a49244e7798b9fcc18a7c6517b98e88bf84dc52e0050abe2ce504365b5579d2b6
DIST idna-2.5.tar.gz 130211 SHA256 3cb5ce08046c4e3a560fc02f138d0ac63e00f8ce5901a56b32ec8b7994082aab SHA512 29a69ede25a8855135c763da5d20ff81832c710038a38521c127d5b7b24b355c6cfa5e9f9a2a4ef1fa4437537d1d9e4b448357e07b4b5e3724d98fee0a3b7835 WHIRLPOOL 8b54100310e57a35eacbdabd14f3e612b5ecbc87335e174ae84aeec4e52d29f4ddd570c5958228b3b7b4bc706cecd16f05862b6669aa9ca5698fe7e7d4eab469
+DIST idna-2.6.tar.gz 135992 SHA256 2c6a5de3089009e3da7c5dde64a141dbc8551d5b7f6cf4ed7c2568d0cc520a8f SHA512 cb5dbfab44c4d11521c67f9d29391f184d1267a3da6dc89f4ed12c60a7a909d5c7474c3ea2bddd0af7063f4f620e87a8dd586bb07e8b961b30b1dd7c969704c2 WHIRLPOOL 8758527e6c57a7f7a669b82609d00646311ce0617d35e9cf7d3f4ee635955b0c844d906f0ff3aec42f59528ae1554df60bf1272c0734fe28e79503e86619fe4e
diff --git a/dev-python/idna/idna-2.6.ebuild b/dev-python/idna/idna-2.6.ebuild
new file mode 100644
index 000000000000..1e1b51d88c0d
--- /dev/null
+++ b/dev-python/idna/idna-2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.python.org/pypi/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}