summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:14:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:45:50 -0600
commitf765a65bff33ecc11b82fe23711e9c33d89d3979 (patch)
treec2f5b83572292cd9425a613d5f73e2413de2ac6e /dev-python/ifaddr/ifaddr-0.1.6.ebuild
parentsci-electronics/drahnr-oregano: Remove obsolete <pkg/> ref (diff)
downloadgentoo-f765a65bff33ecc11b82fe23711e9c33d89d3979.tar.gz
gentoo-f765a65bff33ecc11b82fe23711e9c33d89d3979.tar.bz2
gentoo-f765a65bff33ecc11b82fe23711e9c33d89d3979.zip
dev-python/ifaddr: add for new zeroconf version
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ifaddr/ifaddr-0.1.6.ebuild')
-rw-r--r--dev-python/ifaddr/ifaddr-0.1.6.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ifaddr/ifaddr-0.1.6.ebuild b/dev-python/ifaddr/ifaddr-0.1.6.ebuild
new file mode 100644
index 000000000000..1fc689b62b20
--- /dev/null
+++ b/dev-python/ifaddr/ifaddr-0.1.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enumerate IP addresses on the local network adapters"
+HOMEPAGE="https://github.com/pydron/ifaddr"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""