summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-13 06:46:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-13 07:08:31 +0200
commit521b1b176516020190168b1475aaf37156aa8801 (patch)
tree48a35452f2559d66f3800fd04011caf287660d4a /dev-python/ijson
parentdev-python/pylint-venv: Bump to 3.0.2 (diff)
downloadgentoo-521b1b176516020190168b1475aaf37156aa8801.tar.gz
gentoo-521b1b176516020190168b1475aaf37156aa8801.tar.bz2
gentoo-521b1b176516020190168b1475aaf37156aa8801.zip
dev-python/ijson: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index c4d39d05da09..2b546a9b7eaa 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-3.2.0.post0.gh.tar.gz 127558 BLAKE2B 38e06039bb177c43e4744f145fed2159e317a0b8da628b85a62215cdfe6693b271c39629811513d2e563b532244950616b9105134916bc577446a0b5e5ce25f7 SHA512 b926253a3d6a070e2ac27c61542d340e4a1498de7642957dbe59e9fd3c53d700ed4e8ee71c83efcb90b2c302d15b0d268c38054c10728bbb436521aa5b42050b
+DIST ijson-3.2.1.gh.tar.gz 127577 BLAKE2B 1b3c8ce6d8b01d0cf4af4d8995bcc33d879321ed5b89c4b6baa84ef10cd311a1e66254113a17229c228c26e2b996a52c4b0629b42dbd830f296fd4903b603468 SHA512 2bd3a978016fbbd3f5aca6644778d19478a561f40729206eaa4f14e30fde4ff3b92c8aa33c928cb9e81c678a5a84fa59ab68e747421d725e77c79a9c987e4536
diff --git a/dev-python/ijson/ijson-3.2.1.ebuild b/dev-python/ijson/ijson-3.2.1.ebuild
new file mode 100644
index 000000000000..e0e41874669d
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+# _yajl2 extension is known to be broken
+# https://github.com/ICRAR/ijson/issues/98
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+SRC_URI="
+ https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest