summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-30 07:24:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-30 09:20:30 +0200
commit3432c18599832be3ef942fa63fe7afae68f4c25b (patch)
tree82c6c81a50420faf2fcc8422394ff6e44c27335f /dev-python/imageio
parentdev-python/fsspec: Remove incorrect dep on versioneer (diff)
downloadgentoo-3432c18599832be3ef942fa63fe7afae68f4c25b.tar.gz
gentoo-3432c18599832be3ef942fa63fe7afae68f4c25b.tar.bz2
gentoo-3432c18599832be3ef942fa63fe7afae68f4c25b.zip
dev-python/imageio: Bump to 2.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.19.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 50b3f4781f70..b48ca982990e 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.19.2.gh.tar.gz 388434 BLAKE2B 4f0ec3f2586cbce7c15ff0551b8b5389d9236333eecda0870880c6dbe93bb2de464e57af7bc20c0f63aec6d53040a5140195d09c4c8a3c50c391a42b7847cf49 SHA512 6711a3be92f840d821f6539636072654d000932a6a7688384ae6bc007af5de41c8f90ed9a29e6401fd13219f50082ba5b75a1b383f1ac9242d568f95859de9c4
+DIST imageio-2.19.3.gh.tar.gz 388949 BLAKE2B bf7f7b2cc036d6bc808cedeefe624dfe43b232518f78974fffe9c664f23c8e89da73e5b777ee6049aa0ec363400fe8d9df1388a91a4b0a01089609d7ce12eaf3 SHA512 5ad9f332ea723facd5d9295e463b12d2cc17dfef8a7349ce194a8d32fcc5d07a29550834c66dc6e5837f8440347387b46624243fa267750f986042910ff6cb90
diff --git a/dev-python/imageio/imageio-2.19.3.ebuild b/dev-python/imageio/imageio-2.19.3.ebuild
new file mode 100644
index 000000000000..6770d9759db9
--- /dev/null
+++ b/dev-python/imageio/imageio-2.19.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+)