summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-23 09:21:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-23 10:30:38 +0100
commit5ce2c8f722213539e411d55a88f387ff7c903c47 (patch)
tree1a21267ed430884d07e5f083b5f796a49131e70e /dev-python/imageio
parentdev-python/imageio: Remove old (diff)
downloadgentoo-5ce2c8f722213539e411d55a88f387ff7c903c47.tar.gz
gentoo-5ce2c8f722213539e411d55a88f387ff7c903c47.tar.bz2
gentoo-5ce2c8f722213539e411d55a88f387ff7c903c47.zip
dev-python/imageio: Bump to 2.13.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.13.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 1aeb98ed65ee..f8b5662463f3 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.13.4.gh.tar.gz 340913 BLAKE2B 332d819633a52069265dd0c02163698085b8d0891ee84def78d99f6fb9888752d8f6384c9666dc66d99bc48673648f736eb6f545b67583cae7252caef6f9e499 SHA512 0329a1bfb6906d7f759fec8d5a500cae9a8edaa125d3e4cab7f0e87b2e5eef24655520aecab309de823f9bd8357a1461f772801bac437ed3489804e3c4b40855
+DIST imageio-2.13.5.gh.tar.gz 341447 BLAKE2B 8fd719533325647980355c0a5180a949d1f282ed11fcdb92a0c580f6aa76f799a60f8a3642c72424e557c84c5f1d5a0610cf679d37dcd8d157865c5d19ef94bf SHA512 52b431c3f41ea598d48f1d9c36cd9a5cdaa13365ce5391b832a3ef5dbdb6803435456bd653b509b75ee00452d07b47e43d87ac0c80598bb99f817ee8abe2e74c
diff --git a/dev-python/imageio/imageio-2.13.5.ebuild b/dev-python/imageio/imageio-2.13.5.ebuild
new file mode 100644
index 000000000000..f7d4d4abf4c9
--- /dev/null
+++ b/dev-python/imageio/imageio-2.13.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)
+
+EPYTEST_IGNORE=(
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+)