summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-18 09:28:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-18 09:45:18 +0200
commit73fa48b31246981063507ee0d318602acad00564 (patch)
tree808a0b42ba093e6d88fe5f6d77d2f7ade44e8aab /dev-python/imageio
parentdev-python/imageio: Remove old (diff)
downloadgentoo-73fa48b31246981063507ee0d318602acad00564.tar.gz
gentoo-73fa48b31246981063507ee0d318602acad00564.tar.bz2
gentoo-73fa48b31246981063507ee0d318602acad00564.zip
dev-python/imageio: Bump to 2.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.17.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index c029d9e5a338..b70952104436 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.16.2.gh.tar.gz 366758 BLAKE2B cf2f9f2649f3d5a44d5d8efee19406b38cbb8de6fbd079170fd8eb43f893151f68b256e5d3d1fbb766c7f0562783ca2237e6171785927c8ed69a14840f1acb02 SHA512 1a6e0c9ed58d91fc89810d36acc8f5355ec5f0cf8a7dcc099f3a71cd77bc9d5fcf2821a7bd5f67723be46395290c99e4f478949aa11134f11ff2068504c83c04
+DIST imageio-2.17.0.gh.tar.gz 383819 BLAKE2B 3676fb6c4de9d4a1dea8e240d14702dec760970f4e5655e54acf68530f1833e24f22b938175795d359eac99c63c32e1a99c45501b54729ec4efcc308cdb2e745 SHA512 f6cb4697ceddd43338ef994fc242a921f0c8054655ce63878cc25c8afd28317fadf9806b84f6f337bcc30a61306b451ca29582ddcc1f66e40b6f298620287e11
diff --git a/dev-python/imageio/imageio-2.17.0.ebuild b/dev-python/imageio/imageio-2.17.0.ebuild
new file mode 100644
index 000000000000..d9c5872c4518
--- /dev/null
+++ b/dev-python/imageio/imageio-2.17.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)