summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-28 08:45:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-28 09:00:37 +0200
commit74f459dbed385a2aa68d89adaab757aaf7b63fda (patch)
treebc843db3ea92f16f500a407eaec800856963dfe4 /dev-python/imageio
parentdev-python/peewee: Bump to 3.14.7 (diff)
downloadgentoo-74f459dbed385a2aa68d89adaab757aaf7b63fda.tar.gz
gentoo-74f459dbed385a2aa68d89adaab757aaf7b63fda.tar.bz2
gentoo-74f459dbed385a2aa68d89adaab757aaf7b63fda.zip
dev-python/imageio: Bump to 2.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.10.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index dd7ab85042d1..654b90731b61 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
+DIST imageio-2.10.1.gh.tar.gz 334497 BLAKE2B 979107dec1c18c87a6620be90d68d24e37ae75f7418fafbe67d78fbc3de38b2ccd810e120501061d88a0029674ba814507ac73852b89559413f427986398819b SHA512 2af953f6c2eda3bf1fe3cf74a241bfb7cdb01ff3712f3d7526ceb1aad38499e481fd90eb782324264804c07fcb4425bcd0983be1ef0ec1d86a9b632098944f5a
DIST imageio-2.9.0.gh.tar.gz 298291 BLAKE2B b36b0a5bf74938177353ffce103d7479a2b15442623d400261dac485b5cc7e8743b18e92d938fcfe2b68dfdef1d1417308e5441112ff851481cc768b76ab56d0 SHA512 a325ad4f0913219b87418d4f57fddc3f1e4c1be4102e933aa0c236317044d2a5ded623bbe86b92d3f2004bb9386ccb3f0cc03b7b118f9faa6f320dd147157ed6
diff --git a/dev-python/imageio/imageio-2.10.1.ebuild b/dev-python/imageio/imageio-2.10.1.ebuild
new file mode 100644
index 000000000000..9f303080792f
--- /dev/null
+++ b/dev-python/imageio/imageio-2.10.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+)