summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 09:51:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:26:58 +0200
commit9c108e450a3e4f2a674c7836bd4b466b6948f52a (patch)
treeac1f4000f83dff35ad982bea16ab5268635190fd /dev-python/imageio
parentdev-python/imageio: Remove old (diff)
downloadgentoo-9c108e450a3e4f2a674c7836bd4b466b6948f52a.tar.gz
gentoo-9c108e450a3e4f2a674c7836bd4b466b6948f52a.tar.bz2
gentoo-9c108e450a3e4f2a674c7836bd4b466b6948f52a.zip
dev-python/imageio: Bump to 2.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.19.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 56bf377db341..45d6ed742db2 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.18.0.gh.tar.gz 384312 BLAKE2B 5683ec01db358d9074c5e02c0006bf89e5978418d86b13ce93b1c0fb0800fb650b76d53bd4fdea94c69c185af3341e1e2e80c91815d0f74ebadcaa01ee497e5a SHA512 ddd7606f4b72e3a768b2f7f71d058d11df2bd6e48455240d17b2d93394808158c4f52289ea6f47b5c5655ec45e514aa4413248de0aff1806d28922723540aa50
+DIST imageio-2.19.0.gh.tar.gz 387467 BLAKE2B bd37ed1d8c147159a6e3dc951c512ddd1bdcc5c664ea1cae80d7eed4544b9329e92f711452442a459e776ec151db751d1d1c62a7d9e1165c18dcc5f0d05ec9c2 SHA512 effa3865259a1dab901a1ef2acf2cdbd57db96308b9edd8d489ff7421e51da0b2b8b8b93a7e3003bac43dd010c4f30aa683fd22236ea5d82af9d8d48b7b60db7
diff --git a/dev-python/imageio/imageio-2.19.0.ebuild b/dev-python/imageio/imageio-2.19.0.ebuild
new file mode 100644
index 000000000000..6770d9759db9
--- /dev/null
+++ b/dev-python/imageio/imageio-2.19.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+)