summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-10-05 16:58:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-13 15:34:27 +0200
commitceda8192bf6732a252ef613c538f623d1cc7ffe0 (patch)
treebea9c9389b15c74a08f3b2513ac0d4a20a623989 /dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild
parentprofiles: remove obsolete paramiko masks (diff)
downloadgentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.tar.gz
gentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.tar.bz2
gentoo-ceda8192bf6732a252ef613c538f623d1cc7ffe0.zip
dev-python/indexed_gzip: new package
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Horea Christian <horea.christ@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10077
Diffstat (limited to 'dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild')
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild b/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild
new file mode 100644
index 000000000000..3533fde36c98
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-0.8.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cp conftest.py "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ pytest -vv --nelems 500000 --niters 250 || die
+}