summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2015-12-29 10:54:53 +0100
committerLouis Sautier <sautier.louis@gmail.com>2015-12-29 12:00:21 +0100
commit88d2461cc912d4e2bdb2acdb8709b80485f64fb6 (patch)
tree734b3ca795b86dbb440cf319f11f3dfe81978695 /dev-python/inflect/inflect-0.2.5.ebuild
parentdev-libs/cloog: version 0.18.4 stable on ppc and ppc64, bug #570016 (diff)
downloadgentoo-88d2461cc912d4e2bdb2acdb8709b80485f64fb6.tar.gz
gentoo-88d2461cc912d4e2bdb2acdb8709b80485f64fb6.tar.bz2
gentoo-88d2461cc912d4e2bdb2acdb8709b80485f64fb6.zip
dev-python/inflect: needed as a new dep to dev-python/irc
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/inflect/inflect-0.2.5.ebuild')
-rw-r--r--dev-python/inflect/inflect-0.2.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/inflect/inflect-0.2.5.ebuild b/dev-python/inflect/inflect-0.2.5.ebuild
new file mode 100644
index 000000000000..815b0e90c353
--- /dev/null
+++ b/dev-python/inflect/inflect-0.2.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/pwdyson/inflect.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests tests || die "tests failed with ${EPYTHON}"
+}