summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 09:43:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 11:06:46 +0100
commit3fff2402d0a146fc6bddc1fa2597f74536e808b5 (patch)
tree2b54d9af4a74de438ab4b8b9b4406f62fc324a7b /dev-python/inflect
parentdev-python/xarray: Bump to 0.21.1 (diff)
downloadgentoo-3fff2402d0a146fc6bddc1fa2597f74536e808b5.tar.gz
gentoo-3fff2402d0a146fc6bddc1fa2597f74536e808b5.tar.bz2
gentoo-3fff2402d0a146fc6bddc1fa2597f74536e808b5.zip
dev-python/inflect: Bump to 5.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-5.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index c900f342f03a..243ca8b3461a 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1 +1,2 @@
DIST inflect-5.3.0.tar.gz 74127 BLAKE2B 20c591012a5a6692c3da3a39f4aeaaae290da5ba723af5c9ac90f7d28112a1894acf082633f8f673f6d903f756b9bb70c6c3366762e872cf7ca6c6d5edf1c99c SHA512 f5baf65fb7a6ba59c91a36a17acb0abda3efc74fef56b3a3d99c100b2c6e94c5aafb08ab37310ce410631ac928e9c24a4a4c5e6b5c7d8f907c3d999f4a70cce4
+DIST inflect-5.4.0.tar.gz 68594 BLAKE2B 60898e019c04b9d86a1591c341f48e7e3093eaa4f93bb4f902f4d405f1151d705f902b792028ca97a85ed47ffe509bab758b3ec74878ec82f5dac3c953197ca0 SHA512 48b7d38faf41b3f682226b66ea5493b7d4ff58a8db52c9b90092fc329aee761b090791deeda24234b9f9fa47d8db9b499e1f4304367ef3637c441959e8b8d005
diff --git a/dev-python/inflect/inflect-5.4.0.ebuild b/dev-python/inflect/inflect-5.4.0.ebuild
new file mode 100644
index 000000000000..39ef4de2bce6
--- /dev/null
+++ b/dev-python/inflect/inflect-5.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/jaraco/inflect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-8.2' \
+ '>=dev-python/rst-linker-1.9' dev-python/alabaster
+distutils_enable_tests pytest