summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-25 12:58:23 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-25 12:58:48 +0200
commit297e5cbdd5f61b6ef36a91be1bc1f0c39c6d8b79 (patch)
tree2f8288910b53f769a19bdc561925a33d765dfc37 /dev-python/inflection
parentmedia-libs/openal: Stabilize 1.22.0 arm64, #847367 (diff)
downloadgentoo-297e5cbdd5f61b6ef36a91be1bc1f0c39c6d8b79.tar.gz
gentoo-297e5cbdd5f61b6ef36a91be1bc1f0c39c6d8b79.tar.bz2
gentoo-297e5cbdd5f61b6ef36a91be1bc1f0c39c6d8b79.zip
dev-python/inflection: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/inflection')
-rw-r--r--dev-python/inflection/inflection-0.5.1-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/inflection/inflection-0.5.1-r1.ebuild b/dev-python/inflection/inflection-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..8feea6f41aa1
--- /dev/null
+++ b/dev-python/inflection/inflection-0.5.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A port of Ruby on Rails' inflector to Python"
+HOMEPAGE="https://github.com/jpvanhal/inflection"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest